Bug 714441 - Provide a native systemd service for Fedora 16
Provide a native systemd service for Fedora 16
Status: CLOSED DUPLICATE of bug 697698
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-19 05:38 EDT by Harald Reindl
Modified: 2011-06-21 06:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-21 06:29:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2011-06-19 05:38:02 EDT
please include a systemd-service file for Fedora >= 15

it is a bad behavior that F15 replacing upstart with systemd and most 
services are running in SysV compatibilty mode
Comment 2 Jan F. Chadima 2011-06-20 14:58:36 EDT
(In reply to comment #1)
> You can use these, upstream says license is MIT.
> https://github.com/falconindy/systemd-arch-units/blob/master/service/sshd@.service
> https://github.com/falconindy/systemd-arch-units/blob/master/service/sshd.service
> https://github.com/falconindy/systemd-arch-units/blob/master/socket/sshd.socket
>
It's a joke?

--------

Correctly start/stop openssh is not as easy as you think. Much more improved units are packed in the source rpm or git repo. But there are still unsolved problems.

1) in the case of restart service do not kill user child processes, but in the case of shutdown do kill all user child processes.

2) sshd automatically creates /var/run/sshd.pid => the service pid must have other file name (/var/run/sshd-s.pid) and the file content must be copied from /var/run/sshd.pid after starting sshd by the means of initscript / to distinguish it from the sshd run from command line. 

This 2 problems must be solved before the sshd units may be used. If you can help with it, you will be welcomed.
Comment 3 Jan F. Chadima 2011-06-21 06:29:09 EDT

*** This bug has been marked as a duplicate of bug 697698 ***

Note You need to log in before you can comment on or make changes to this bug.