Bug 714466 - Mediatomb fails to categorize media files
Mediatomb fails to categorize media files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mediatomb (Show other bugs)
15
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Rich Mattes
Fedora Extras Quality Assurance
:
: 716672 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-19 08:56 EDT by giulix
Modified: 2011-07-12 01:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: mediatomb-0.12.1-12.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-12 01:07:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RPM build error with JS 1.70* (2.14 KB, application/octet-stream)
2011-06-25 14:26 EDT, Jean Bono
no flags Details

  None (edit)
Description giulix 2011-06-19 08:56:10 EDT
Description of problem: Mediatomb scripting support is impaired

Version-Release number of selected component (if applicable): 0.12.1


How reproducible: Always


Steps to Reproduce:
1. Start mediatomb
2. Add media content
3.
  
Actual results:
"ERROR: missing objectType property" and media file is not categorized

Expected results:
Media files are correctly processed by the JS engine and categorized

Additional info:
This post on mediatomb's forum sums it up pretty well:
http://sourceforge.net/projects/mediatomb/forums/forum/440751/topic/4547840
It also offers a solution, unfortunately it seems impractical as it involves replacing the seamonkey JS engine with an old version
Comment 1 Jean Bono 2011-06-25 14:26:39 EDT
Created attachment 509912 [details]
RPM build error with JS 1.70*
Comment 2 Rich Mattes 2011-06-27 17:24:51 EDT
*** Bug 716672 has been marked as a duplicate of this bug. ***
Comment 3 Rich Mattes 2011-06-27 17:26:56 EDT
(In reply to comment #1)
> Created attachment 509912 [details]
> RPM build error with JS 1.70*

The SRPM that builds against js-1.8 contains a patch that makes it incompatible with js-1.70.  You'll need to pull the patch out of the spec file to rebuild the RPM against js-1.70
Comment 4 Rich Mattes 2011-06-28 00:53:21 EDT
Despite the fact that I know nothing about Spidermonkey, I have a build of mediatomb that seems to be working well with js-1.8 using the default import.js and playlists.js.  Please try it and get back to me in this bug, if it solves your issues I will push it to stable and submit the js-1.8 patches upstream for consideration.

You can download the packages from koji for your architecture (this will require unblocking and updating to js-1.8):
http://koji.fedoraproject.org/koji/taskinfo?taskID=3165206

Note that you may want to add "-D" to the MT_OPTIONS in /etc/mediatomb.conf for testing, this enables a lot of extra debug output in /var/log/mediatomb (assuming you're running mediatomb as a service using /etc/init.d/mediatomb)
Comment 5 Michael Weidner 2011-06-28 01:58:47 EDT
Patch seems to work for me, my import.js does its job again.
Comment 6 giulix 2011-06-29 17:50:51 EDT
Confirmed that media items are correctly categorized with mediatomb-0.12.1-11.fc15.i686.rpm. Thanks for sorting this out
Comment 7 Fedora Update System 2011-06-29 22:23:45 EDT
mediatomb-0.12.1-12.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mediatomb-0.12.1-12.fc15
Comment 8 Fedora Update System 2011-06-30 14:57:54 EDT
Package mediatomb-0.12.1-12.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mediatomb-0.12.1-12.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mediatomb-0.12.1-12.fc15
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2011-07-12 01:07:18 EDT
mediatomb-0.12.1-12.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.