Bug 71452 - (SCSI 440GX)Installer Hangs due to ICP Vortex driver
(SCSI 440GX)Installer Hangs due to ICP Vortex driver
Status: CLOSED DUPLICATE of bug 79752
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-13 15:59 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-13 15:59:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
The installer detects an aix7xxx scsi interface instead of the ICP vortex that the machine has.  It DOES see the disks, however when it tries to install the first rpm (I believe glibc) it hangs.  No error messages and cannot switch VTs.  Solution was to "boot: linux noprobe" and manually load the isc driver.  This seems to work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot installer 
2. Install
3. 
 

Actual Results:  Hangs before completing installation of first rpm

Expected Results:  complete installation

Additional info:

Dual Pentium III 850 on a L440GX intel board.  1024MB memory, ICP Vortex RAID card, 2 IBM ultrastar drives in raid 1 config.
Comment 1 Jeremy Katz 2002-08-14 00:07:30 EDT
Could you attach the output of 'lspci -v' and 'lspci -vn'?
Comment 2 Need Real Name 2002-08-14 09:35:45 EDT
lspci -v

00:00.0 Host bridge: Intel Corp. 440GX - 82443GX Host bridge
        Flags: bus master, medium devsel, latency 64
        Memory at f8000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: Intel Corp. 440GX - 82443GX AGP bridge (prog-if 00 [Normal
decode])
        Flags: bus master, 66Mhz, medium devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=02, sec-latency=64
        I/O behind bridge: 00003000-00003fff
        Memory behind bridge: f4200000-f42fffff
        Prefetchable memory behind bridge: fc000000-fc0fffff

00:0c.0 SCSI storage controller: Adaptec AIC-7896U2/7897U2
        Subsystem: Adaptec: Unknown device 0053
        Flags: bus master, medium devsel, latency 64, IRQ 10
        BIST result: 00
        I/O ports at 2400 [size=256]
        Memory at f4101000 (64-bit, non-prefetchable) [size=4K]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [dc] Power Management version 1

00:0c.1 SCSI storage controller: Adaptec AIC-7896U2/7897U2
        Subsystem: Adaptec: Unknown device 0053
        Flags: bus master, medium devsel, latency 64, IRQ 10
        BIST result: 00
        I/O ports at 2800 [size=256]
        Memory at f4102000 (64-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 1

00:0e.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
        Subsystem: Intel Corp. 82559 Fast Ethernet LAN on Motherboard
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at f4100000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at 2000 [size=64]
        Memory at f4000000 (32-bit, non-prefetchable) [size=1M]
        Expansion ROM at <unassigned> [disabled] [size=1M]
        Capabilities: [dc] Power Management version 2

00:12.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
        Flags: bus master, medium devsel, latency 0

00:12.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-if 80
[Master])
        Flags: bus master, medium devsel, latency 64
        I/O ports at 2040 [size=16]

00:12.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01) (prog-if 00
[UHCI])
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at 2060 [size=32]

00:12.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
        Flags: medium devsel, IRQ 9

00:14.0 VGA compatible controller: Cirrus Logic GD 5480 (rev 23) (prog-if 00 [VGA])
        Subsystem: Cirrus Logic CL-GD5480
        Flags: bus master, medium devsel, latency 64
        Memory at f6000000 (32-bit, prefetchable) [size=32M]
        Memory at f4103000 (32-bit, non-prefetchable) [size=4K]
        Expansion ROM at <unassigned> [disabled] [size=32K]

01:0f.0 PCI bridge: Digital Equipment Corporation DECchip 21150 (rev 06)
(prog-if 00 [Normal decode])
        Flags: bus master, fast Back2Back, 66Mhz, medium devsel, latency 240
        Bus: primary=01, secondary=02, subordinate=02, sec-latency=68
        I/O behind bridge: 00003000-00003fff
        Memory behind bridge: f4200000-f42fffff
        Prefetchable memory behind bridge: 00000000fc000000-00000000fc000000
        Capabilities: [dc] Power Management version 1

02:04.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 0c)
        Subsystem: Intel Corp. EtherExpress PRO/100 S Server Adapter
        Flags: bus master, medium devsel, latency 208, IRQ 5
        Memory at f4220000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at 3000 [size=64]
        Memory at f4200000 (32-bit, non-prefetchable) [size=128K]
        Capabilities: [dc] Power Management version 2

02:07.0 SCSI storage controller: ICP Vortex Computersysteme GmbH GDT 6538RS/6638RS
        Subsystem: ICP Vortex Computersysteme GmbH GDT 6538RS/6638RS
        Flags: bus master, fast Back2Back, medium devsel, latency 208, IRQ 11
        Memory at fc000000 (32-bit, prefetchable) [size=16K]
        Expansion ROM at <unassigned> [disabled] [size=32K]
        Capabilities: [80] Power Management version 2
--------------------------------------------------------------------

lspci -vn
00:00.0 Class 0600: 8086:71a0
        Flags: bus master, medium devsel, latency 64
        Memory at f8000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [a0] AGP version 1.0

00:01.0 Class 0604: 8086:71a1
        Flags: bus master, 66Mhz, medium devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=02, sec-latency=64
        I/O behind bridge: 00003000-00003fff
        Memory behind bridge: f4200000-f42fffff
        Prefetchable memory behind bridge: fc000000-fc0fffff

00:0c.0 Class 0100: 9005:005f
        Subsystem: 9004:0053
        Flags: bus master, medium devsel, latency 64, IRQ 10
        BIST result: 00
        I/O ports at 2400 [size=256]
        Memory at f4101000 (64-bit, non-prefetchable) [size=4K]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [dc] Power Management version 1

00:0c.1 Class 0100: 9005:005f
        Subsystem: 9004:0053
        Flags: bus master, medium devsel, latency 64, IRQ 10
        BIST result: 00
        I/O ports at 2800 [size=256]
        Memory at f4102000 (64-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 1

00:0e.0 Class 0200: 8086:1229 (rev 08)
        Subsystem: 8086:3000
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at f4100000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at 2000 [size=64]
        Memory at f4000000 (32-bit, non-prefetchable) [size=1M]
        Expansion ROM at <unassigned> [disabled] [size=1M]
        Capabilities: [dc] Power Management version 2

00:12.0 Class 0601: 8086:7110 (rev 02)
        Flags: bus master, medium devsel, latency 0

00:12.1 Class 0101: 8086:7111 (rev 01) (prog-if 80 [Master])
        Flags: bus master, medium devsel, latency 64
        I/O ports at 2040 [size=16]

00:12.2 Class 0c03: 8086:7112 (rev 01)
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at 2060 [size=32]

00:12.3 Class 0680: 8086:7113 (rev 02)
        Flags: medium devsel, IRQ 9

00:14.0 Class 0300: 1013:00bc (rev 23)
        Subsystem: 1013:00bc
        Flags: bus master, medium devsel, latency 64
        Memory at f6000000 (32-bit, prefetchable) [size=32M]
        Memory at f4103000 (32-bit, non-prefetchable) [size=4K]
        Expansion ROM at <unassigned> [disabled] [size=32K]

01:0f.0 Class 0604: 1011:0023 (rev 06)
        Flags: bus master, fast Back2Back, 66Mhz, medium devsel, latency 240
        Bus: primary=01, secondary=02, subordinate=02, sec-latency=68
        I/O behind bridge: 00003000-00003fff
        Memory behind bridge: f4200000-f42fffff
        Prefetchable memory behind bridge: 00000000fc000000-00000000fc000000
        Capabilities: [dc] Power Management version 1

02:04.0 Class 0200: 8086:1229 (rev 0c)
        Subsystem: 8086:1040
        Flags: bus master, medium devsel, latency 208, IRQ 5
        Memory at f4220000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at 3000 [size=64]
        Memory at f4200000 (32-bit, non-prefetchable) [size=128K]
        Capabilities: [dc] Power Management version 2

02:07.0 Class 0100: 1119:013a
        Subsystem: 1119:013a
        Flags: bus master, fast Back2Back, medium devsel, latency 208, IRQ 11
        Memory at fc000000 (32-bit, prefetchable) [size=16K]
        Expansion ROM at <unassigned> [disabled] [size=32K]
        Capabilities: [80] Power Management version 2
Comment 3 Bill Nottingham 2002-08-23 16:15:11 EDT
If the installer is hanging, this is probably a kernel issue with one of the two
drivers.
Comment 4 Arjan van de Ven 2002-08-23 16:21:12 EDT
did you use the apic option ?
Comment 5 Need Real Name 2002-08-23 16:42:41 EDT
Not familiar with the apic option, so I don't think so.
Comment 6 Arjan van de Ven 2002-08-23 16:54:08 EDT
ok please type
linux apic

on the very very first screen; that works around most of the 440GX issues...
Comment 7 Alan Cox 2003-06-08 07:31:59 EDT

*** This bug has been marked as a duplicate of 79752 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:49:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.