Bug 71454 - methoeds of exiting windowed shell have different behavior
methoeds of exiting windowed shell have different behavior
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
8.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-13 16:08 EDT by Norm Murray
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 13:49:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Norm Murray 2002-08-13 16:08:20 EDT
Description of Problem:

When a terminal (gnome-terminal or xterm tested) is exited via the window
manager (destroying the window, or using the x button), child processes are
killed. If the shell itself is exited with control-d child processes remain active. 

This happens with both metacity and sawfish window managers. 

The inconsistent behaviour is bad UI... and I would argue that child processes
which have been backgrounded should remain alive in both cases. (which is the
behaviour seen with tcsh for example )

To reproduce: 
xterm
(in the new terminal) xeyes &
close the xterm window, and xeyes will also exit. 

If you start tcsh before running xeyes, the xeyes will persist after the xterm
is closed.
Comment 1 Bernhard Rosenkraenzer 2002-08-30 06:19:58 EDT
Works as intended in KDE... 
Bug in gnome-terminal?
Comment 2 Havoc Pennington 2002-08-30 13:23:20 EDT
Every terminal I've ever used has worked this way (you have to type "disown" 
in bash to keep a background job from dying with the terminal).

I can see how it might be considered a feature, e.g. if you kill a window
containing an ssh session you probably want the ssh session to die, right?

I don't really know in detail why the jobs die though (SIGHUP?)
Comment 3 Norm Murray 2002-08-30 14:46:14 EDT
In the case of the ssh session, I would expect it to still be active in the
shell rather than something which had detached. 

And I at least see the same behaviour with konsole, xterm and gnome-terminal
when running bash, but not with tcsh.
Comment 4 Ray Strode [halfline] 2004-11-09 13:49:03 EST
Hi Norm,

This behavior is defined by your login shell.  If you feel the
behavior of your shell is wrong, please open a bug filed against the
component for your shell.  

Thanks.

Note You need to log in before you can comment on or make changes to this bug.