Bug 71466 - exit code not set
exit code not set
Status: CLOSED DUPLICATE of bug 67163
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-13 18:48 EDT by Shawn McMahon
Modified: 2015-01-07 18:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn McMahon 2002-08-13 18:48:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
up2date does not set the exit code when it gets an error.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. up2date-nox -u
2. If it fails to connect because the service is busy, an error code 51 is
generated, but up2date exits with an exit code of 0.
3.  echo $?

	

Actual Results:  0

Expected Results:  1 or 51

Additional info:

This prevents rational scripting.  My script reports success, and later I find
out that it wasn't successful at all because up2date is reporting bogus status.

Status "normal" because the workaround is non-trivial.
Comment 1 Adrian Likins 2004-08-20 15:37:35 EDT

*** This bug has been marked as a duplicate of 67163 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:49:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.