Bug 714702 - Legacy SysV initscript file must go into an optional subpackage.
Legacy SysV initscript file must go into an optional subpackage.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 697524 (view as bug list)
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-06-20 09:26 EDT by Jóhann B. Guðmundsson
Modified: 2011-09-30 15:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.0-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 15:45:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2011-06-20 09:26:57 EDT
Description of problem:

Currently your component is providing both native systemd service files and
legacy sysv init script in the same package which is in violation of the
packaging guidelines[1]. 

Once a native systemd service file is shipped and if the intention is to
continue to maintain and ship the old sysv initscript the old sysvinit must go
into an optional subpackage.

"SysV Initscripts
Packages may also provide a SysV initscript file, but are not required to do
so. This format is considered legacy, but Fedora still contains init mechanisms
such as upstart which do not support the systemd unit file format. If present,
the SysV initscript(s) must go into an optional subpackage, so as not to
confuse sysadmins. The guidelines for SysV initscripts can be found here:
Packaging:SysVInitScript"

1.http://fedoraproject.org/wiki/Packaging:Guidelines:Systemd

Version-Release number of selected component (if applicable):

NetworkManager-1:0.8.9997-1.git20110531.fc16.x86_64.rpm

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-07-15 11:09:14 EDT
What's the current status of you are one of few that is not package
native systemd unit in the Base group correctly?

If you dont have the time to fix this should I try to find a proven packager to
do the work for you? 

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
https://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 2 Dan Williams 2011-07-18 23:16:30 EDT
I've elected to disable the sysv initscript when systemd is enabled.  That change has been made upstream as 530f2674d48d100e42c83ea414dc877ad4b55ee9, so this bug can be closed when that fix rolls out.  As systemd is an integral part of the Fedora system, there's not much point in having a sysv initscript for NM too.
Comment 3 Dan Williams 2011-07-18 23:17:29 EDT
*** Bug 697524 has been marked as a duplicate of this bug. ***
Comment 4 Mads Kiilerich 2011-08-10 03:58:54 EDT
I assume this is included in NetworkManager-0.8.9997-7.git20110721.fc16.i686 in f16 which doesn't have /etc/rc.d/init.d/NetworkManager? 

However, that causes failure on installation (when building livecd):
  Installing: NetworkManager               ##################### [489/616]error reading information on service NetworkManager: No such file or directory
error reading information on service NetworkManager: No such file or directory

The chkconfig invocations in the %post script should be removed too.
Comment 5 Orion Poplawski 2011-08-31 12:01:34 EDT
The %post error is still in NetworkManager-0.9.0-1.fc16.
Comment 6 Fedora Update System 2011-09-09 14:43:24 EDT
NetworkManager-0.9.0-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.0-2.fc16
Comment 7 Fedora Update System 2011-09-10 14:57:50 EDT
Package NetworkManager-0.9.0-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.0-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.9.0-2.fc16
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2011-09-30 15:45:30 EDT
NetworkManager-0.9.0-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.