Bug 714746 - Xorg crash in record when ProcDRI2WaitMSCReply called
Summary: Xorg crash in record when ProcDRI2WaitMSCReply called
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 15
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 748158 751459 752209 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-20 15:22 UTC by Yijun Yuan
Modified: 2018-04-11 07:31 UTC (History)
5 users (show)

Fixed In Version: xorg-x11-server-1.11.2-3.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-14 00:52:56 UTC
Type: ---


Attachments (Terms of Use)
System time is adjusted several times to verify the steps (134.83 KB, text/plain)
2011-06-20 15:22 UTC, Yijun Yuan
no flags Details
Xorg.0.log.old when crash happened at 22:18 (29.53 KB, application/octet-stream)
2011-06-22 15:43 UTC, Yijun Yuan
no flags Details
Xorg.0.log.old when crash happened at 22:18 (29.53 KB, text/plain)
2011-06-22 15:45 UTC, Yijun Yuan
no flags Details

Description Yijun Yuan 2011-06-20 15:22:23 UTC
Created attachment 505637 [details]
System time is adjusted several times to verify the steps

Description of problem:
Xorg would crash if time were 22:00 (my zone is +0800) and I opened a tab and enter a URL in Firefox.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.10.2-1.fc15.i686
firefox-4.0.1-2.fc15.i686
gnome-shell-3.0.2-1.fc15.i686
mutter-3.0.2.1-1.fc15.i686

How reproducible:
Almost everytime

Steps to Reproduce:
1. Set system time to 21:59 +0800
2. Open Firefox, press ctrl-t to open new tab, enter new URL (select from history), then press Enter. Close tab once it loads.
3. Repeat step #2
  
Actual results:
gnome-shell exit and gdm "Login" screen appears

Expected results:
Firefox should load page normally

Additional info:
Attached system "messages" file.

Comment 1 Matěj Cepl 2011-06-20 22:16:29 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Looking at the /var/log/messages you presented:

bradford:build $ curl -s 'https://bugzilla.redhat.com/attachment.cgi?id=505637'|grep 'abrt.*saved core dump'|sed -e 's/[^(]*(\([^)]*\)).*/\1/'|sort -u
/usr/bin/skype
/usr/bin/Xorg
/usr/libexec/gsd-datetime-mechanism
/usr/lib/nspluginwrapper/npviewer.bin
bradford:build $ 

I would ignore npviewer.bin (which is most likely a crash in the proprietary flash-plugin) and skype.

Given the sensitivity on time, I would vote for gsd-datetime-mechanism being the problem, but I would be interested in Xorg issue as well.

Please, go to /var/log and find Xorg.*.log which contains a backtrace

grep Backtrace /var/log/Xorg*

Please attach this file and also

* your X server config file (/etc/X11/xorg.conf, if available), and
* /var/log/Xorg.0.log

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Yijun Yuan 2011-06-21 15:09:27 UTC
Cannot reproduce it today, so no logs available, sorry. I'd re-open this ticket once I got the logs.

Comment 3 Yijun Yuan 2011-06-22 15:43:47 UTC
Created attachment 506044 [details]
Xorg.0.log.old when crash happened at 22:18

Comment 4 Yijun Yuan 2011-06-22 15:44:40 UTC
Not related with time -- experienced two crash at both 22:18 and 22:47, so the "22:00 crash" was a mistake. Xorg.0.log.old attached.

Comment 5 Yijun Yuan 2011-06-22 15:45:25 UTC
Created attachment 506045 [details]
Xorg.0.log.old when crash happened at 22:18

Comment 6 Matěj Cepl 2011-08-04 21:59:13 UTC
Backtrace:
[   488.411] 0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80e8cbc]
[   488.411] 1: /usr/bin/Xorg (0x8047000+0x60846) [0x80a7846]
[   488.411] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0x70740c]
[   488.411] 3: /usr/lib/xorg/modules/extensions/librecord.so (0xb19000+0x2130) [0xb1b130]
[   488.411] 4: /usr/bin/Xorg (_CallCallbacks+0x3e) [0x8075f2e]
[   488.411] 5: /usr/bin/Xorg (WriteToClient+0x26f) [0x80a63df]
[   488.411] 6: /usr/lib/xorg/modules/extensions/libdri2.so (ProcDRI2WaitMSCReply+0x63) [0x9eae13]
[   488.411] 7: /usr/lib/xorg/modules/extensions/libdri2.so (DRI2WaitMSCComplete+0x76) [0x9e91d6]
[   488.411] 8: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb27000+0x24283) [0xb4b283]
[   488.411] 9: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb27000+0xa204) [0xb31204]
[   488.411] 10: /usr/lib/libdrm.so.2 (drmHandleEvent+0xd6) [0x4f945a76]
[   488.411] 11: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb27000+0xa26f) [0xb3126f]
[   488.411] 12: /usr/bin/Xorg (WakeupHandler+0x55) [0x8075725]
[   488.412] 13: /usr/bin/Xorg (WaitForSomething+0x1ba) [0x80a0daa]
[   488.412] 14: /usr/bin/Xorg (0x8047000+0x2a0ee) [0x80710ee]
[   488.412] 15: /usr/bin/Xorg (0x8047000+0x1d38c) [0x806438c]
[   488.412] 16: /lib/libc.so.6 (__libc_start_main+0xf3) [0x4e58f413]
[   488.412] 17: /usr/bin/Xorg (0x8047000+0x1d6a1) [0x80646a1]

Comment 9 Adam Jackson 2011-11-09 20:29:52 UTC
*** Bug 751459 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2011-11-10 19:46:19 UTC
xorg-x11-server-1.11.2-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.11.2-3.fc16

Comment 11 Adam Jackson 2011-11-10 22:03:15 UTC
*** Bug 752209 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2011-11-11 01:24:27 UTC
Package xorg-x11-server-1.11.2-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-1.11.2-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15733
then log in and leave karma (feedback).

Comment 13 Kjartan Maraas 2011-11-11 16:48:30 UTC
*** Bug 748158 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Update System 2011-11-14 00:52:56 UTC
xorg-x11-server-1.11.2-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.