This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 714758 - [abrt] parted-2.3-4.fc14: ped_assert: Process /sbin/partprobe was killed by signal 6 (SIGABRT)
[abrt] parted-2.3-4.fc14: ped_assert: Process /sbin/partprobe was killed by s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
14
i686 Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:f80fa848996c5a62bc30170464f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-20 11:51 EDT by Flos Lonicerae
Modified: 2011-12-03 21:45 EST (History)
3 users (show)

See Also:
Fixed In Version: parted-2.3-5.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-03 21:41:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (7.15 KB, text/plain)
2011-06-20 11:51 EDT, Flos Lonicerae
no flags Details
first 512B of my hardisk (513 bytes, application/x-gzip)
2011-09-21 12:31 EDT, Flos Lonicerae
no flags Details

  None (edit)
Description Flos Lonicerae 2011-06-20 11:51:22 EDT
abrt version: 1.1.18
architecture: i686
Attached file: backtrace, 7325 bytes
cmdline: partprobe
component: parted
Attached file: coredump, 536576 bytes
crash_function: ped_assert
executable: /sbin/partprobe
kernel: 2.6.35.13-91.fc14.i686
package: parted-2.3-4.fc14
rating: 4
reason: Process /sbin/partprobe was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1308572008
uid: 0

How to reproduce
-----
after i modify my partition table, use partprobe to sync my hard disk, core dumped...

my system:
FC14

my partition table:
# fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x4d74c238

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63      610469      305203+  83  Linux
/dev/sda2          610470   123491654    61440592+  83  Linux
/dev/sda3       123491655   184924214    30716280    c  W95 FAT32 (LBA)
/dev/sda4       184924215   625137344   220106565    f  W95 Ext'd (LBA)
/dev/sda5       184924278   287322524    51199123+   7  HPFS/NTFS
/dev/sda6       287322588   389720834    51199123+   7  HPFS/NTFS
/dev/sda7       389720898   408147389     9213246   af  HFS / HFS+
/dev/sda8   *   408147453   469579949    30716248+  af  HFS / HFS+
/dev/sda9       469580013   475716779     3068383+  82  Linux swap / Solaris
/dev/sda10      475716843   625137344    74710251   83  Linux
Comment 1 Flos Lonicerae 2011-06-20 11:51:26 EDT
Created attachment 505654 [details]
File: backtrace
Comment 2 Brian Lane 2011-07-22 11:37:55 EDT
What does the output of parted -l show?
Comment 3 Flos Lonicerae 2011-09-21 12:20:25 EDT
Package: parted-2.3-4.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. parted->print->crashed!
2.
3.
Comment 4 Flos Lonicerae 2011-09-21 12:22:41 EDT
Hi Brian,

[root@localhost ~]# parted -l
Backtrace has 17 calls on stack:
  17: /lib/libparted.so.0(ped_assert+0x2b) [0x813bbb]
  16: /lib/libparted.so.0(ped_geometry_read+0x11f) [0x81d67f]
  15: /lib/libparted.so.0(hfsplus_probe+0x424) [0x83dfb4]
  14: /lib/libparted.so.0(ped_file_system_probe_specific+0x6e) [0x81562e]
  13: /lib/libparted.so.0(ped_file_system_probe+0x81) [0x815741]
  12: /lib/libparted.so.0() [0x84cf0b]
  11: /lib/libparted.so.0() [0x84d027]
  10: /lib/libparted.so.0() [0x84d027]
  9: /lib/libparted.so.0() [0x84d027]
  8: /lib/libparted.so.0() [0x84cf6d]
  7: /lib/libparted.so.0() [0x84d540]
  6: /lib/libparted.so.0(ped_disk_new+0x75) [0x81bc95]
  5: parted() [0x804c68b]
  4: parted() [0x804d7a8]
  3: parted(main+0x1971) [0x8052871]
  2: /lib/libc.so.6(__libc_start_main+0xe6) [0x435e36]
  1: parted() [0x804bb91]
已放弃 (core dumped)

---
Flos
Comment 5 Flos Lonicerae 2011-09-21 12:28:58 EDT
BTW: even creating partition interfaces of anaconda gui or console setup of F14 or F13 have the same problem.
Comment 6 Flos Lonicerae 2011-09-21 12:31:28 EDT
Created attachment 524242 [details]
first 512B of my hardisk

first 512 Bytes of my Hardisk(/dev/sda)
Comment 7 Flos Lonicerae 2011-09-21 12:32:16 EDT
[root@localhost ~]# fdisk -l /dev/sda

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x4d74c238

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63      610469      305203+  83  Linux
/dev/sda2          610470   123491654    61440592+  83  Linux
/dev/sda3       123491655   184924214    30716280    c  W95 FAT32 (LBA)
/dev/sda4       184924215   625137344   220106565    f  W95 Ext'd (LBA)
/dev/sda5       184924278   287322524    51199123+   7  HPFS/NTFS
/dev/sda6       287322588   389720834    51199123+   7  HPFS/NTFS
/dev/sda7       389720898   408147389     9213246   eb  BeOS fs
/dev/sda8   *   408147453   469579949    30716248+  af  HFS / HFS+
/dev/sda9       469580013   475716779     3068383+  82  Linux swap / Solaris
/dev/sda10      475716843   625137344    74710251   83  Linux
[root@localhost ~]#
Comment 8 Brian Lane 2011-09-21 13:00:05 EDT
The backtrace looks like the one that shows up when there is a very short partition (< 8 block) but I see that all of yours are nowhere near that small. Thanks for the additional info.
Comment 9 Brian Lane 2011-10-06 12:03:09 EDT
Could you give this scratch build a try? 

http://koji.fedoraproject.org/koji/taskinfo?taskID=3409804

The hfs probe code looks like it checks the size of the partition pretty well, but there were a few spots where device-supplied values, if they were wrong, could result in negative values.
Comment 10 Flos Lonicerae 2011-10-07 13:05:23 EDT
Hi,

very good! it seems the problem has gone! :D i rebuild the SRPM in my Fedora 14 successfully. here is my result:
-----------------------------------
[xx@xx]sudo yum-builddep parted-3.0-3.fc17.src.rpm 
总下载量:221 k
Installed size: 461 k
确定吗?[y/N]:y
下载软件包:
(1/3): device-mapper-devel-1.02.63-2.fc14.i686.rpm                                                    |  94 kB     00:01     
(2/3): libblkid-devel-2.18-4.8.fc14.i686.rpm                                                          |  60 kB     00:01     
(3/3): libudev-devel-161-10.fc14.i686.rpm                                                             |  67 kB     00:00     
-----------------------------------------------------------------------------------------------------------------------------
总计                                                                                          47 kB/s | 221 kB     00:04     
运行 rpm_check_debug 
执行事务测试
事务测试成功
执行事务
  正在安装       : libudev-devel-161-10.fc14.i686                                                                        1/3 
  正在安装       : device-mapper-devel-1.02.63-2.fc14.i686                                                               2/3 
  正在安装       : libblkid-devel-2.18-4.8.fc14.i686                                                                     3/3 

已安装:
  device-mapper-devel.i686 0:1.02.63-2.fc14                        libblkid-devel.i686 0:2.18-4.8.fc14                       

作为依赖被安装:
  libudev-devel.i686 0:161-10.fc14                                                                                           

完毕!

[xx@xx]$ rpmbuild --rebuild parted-3.0-3.fc17.src.rpm
...
Checking for unpackaged file(s): /usr/lib/rpm/check-files /pub/RPM_build/BUILDROOT/parted-3.0-3.fc17.i386
Wrote: /pub/RPM_build/RPMS/i686/parted-3.0-3.fc14.i686.rpm
Wrote: /pub/RPM_build/RPMS/i686/parted-devel-3.0-3.fc14.i686.rpm
Wrote: /pub/RPM_build/RPMS/i686/parted-debuginfo-3.0-3.fc14.i686.rpm
...

[root@localhost i686]# ls
compat-wireless-debuginfo-2011_08_27-1.fc14.i686.rpm  kmod-compat-wireless-2.6.39-1.fc14.3.i686.rpm
compat-wireless-debuginfo-2011_08_27-3.fc14.i686.rpm  mldonkey
compat-wireless-debuginfo-2.6.39-1.fc14.3.i686.rpm    paco-1.10.12-4.fc14.i686.rpm
ghex-2.24.0-5.fc14.i686.rpm                           paco-debuginfo-1.10.12-4.fc14.i686.rpm
ghex-debuginfo-2.24.0-5.fc14.i686.rpm                 paco-gpaco-1.10.12-4.fc14.i686.rpm
ghex-devel-2.24.0-5.fc14.i686.rpm                     parted-3.0-3.fc14.i686.rpm
guitone-1.0-0.1.rc4.fc12.i686.rpm                     parted-debuginfo-3.0-3.fc14.i686.rpm
guitone-debuginfo-1.0-0.1.rc4.fc12.i686.rpm           parted-devel-3.0-3.fc14.i686.rpm
kmod-compat-wireless-2011_08_27-1.fc14.i686.rpm       reiserfs-utils-3.6.21-2.fc14.i686.rpm
kmod-compat-wireless-2011_08_27-3.fc14.i686.rpm       reiserfs-utils-debuginfo-3.6.21-2.fc14.i686.rpm

[root@localhost i686]# rpm -e parted
error: Failed dependencies:
	libparted.so.0 is needed by (installed) udisks-1.0.2-4.fc14.i686
	libparted.so.0 is needed by (installed) pyparted-3.4-5.fc14.i686

[root@localhost i686]# rpm -e parted --nodeps

[root@localhost i686]# rpm -Uvh parted-3.0-3.fc14.i686.rpm 
Preparing...                ########################################### [100%]
   1:parted                 ########################################### [100%]
[root@localhost i686]# rpm -Uvh parted-debuginfo-3.0-3.fc14.i686.rpm 
Preparing...                ########################################### [100%]
   1:parted-debuginfo       ########################################### [100%]
[root@localhost i686]# parted -v
parted (GNU parted) 3.0
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by <http://git.debian.org/?p=parted/parted.git;a=blob_plain;f=AUTHORS>.
[root@localhost i686]# parted -l
Model: ATA WDC WD3200AAJS-0 (scsi)
Disk /dev/sda: 320GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system     标志
 1      32.3kB  313MB   313MB   primary   ext4
 2      313MB   63.2GB  62.9GB  primary   ext4
 3      63.2GB  94.7GB  31.5GB  primary   fat32           lba
 4      94.7GB  320GB   225GB   extended                  lba
 5      94.7GB  147GB   52.4GB  logical   ntfs
 6      147GB   200GB   52.4GB  logical   ntfs
 7      200GB   209GB   9434MB  logical   hfs+
 8      209GB   240GB   31.5GB  logical                   启动
 9      240GB   244GB   3142MB  logical   linux-swap(v1)
10      244GB   320GB   76.5GB  logical   reiserfs


[root@localhost i686]# 

-----------------------------------

BTW, hfs reminds me that i did install a Kalyway 10.5.2 MacOSX on my computer(CPU: Pentuim4). maybe it wrote something in its partition...
Comment 11 Flos Lonicerae 2011-10-07 13:09:49 EDT
but it seems that parted cannot recognize filesystem of the 8th partition, which can be show by fdisk. and the 7th should be BeOS?

-----------------------------------
[root@localhost i686]# fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x4d74c238

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63      610469      305203+  83  Linux
/dev/sda2          610470   123491654    61440592+  83  Linux
/dev/sda3       123491655   184924214    30716280    c  W95 FAT32 (LBA)
/dev/sda4       184924215   625137344   220106565    f  W95 Ext'd (LBA)
/dev/sda5       184924278   287322524    51199123+   7  HPFS/NTFS
/dev/sda6       287322588   389720834    51199123+   7  HPFS/NTFS
/dev/sda7       389720898   408147389     9213246   eb  BeOS fs
/dev/sda8   *   408147453   469579949    30716248+  af  HFS / HFS+
/dev/sda9       469580013   475716779     3068383+  82  Linux swap / Solaris
/dev/sda10      475716843   625137344    74710251   83  Linux
Comment 12 Flos Lonicerae 2011-10-07 13:17:11 EDT
and i have another small request, could this fix be ported to Fedora 16? because  parted of any previous version cannot be run on my computer by anaconda. :P
Thanks !!!
Comment 13 Brian Lane 2011-10-07 13:20:14 EDT
Thanks for testing this. I think I'd classify that as a new bug (not detecting BeOS correctly).
Comment 14 Flos Lonicerae 2011-10-07 21:02:53 EDT
that's ok. since this bug has been fixed, should i change the STATUS to CLOSED or wait others to confirm it?
Comment 15 Brian Lane 2011-10-10 12:18:02 EDT
It will get closed when I submit an update for F14. Thanks.
Comment 16 Fedora Update System 2011-10-11 14:31:44 EDT
parted-3.0-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/parted-3.0-3.fc16
Comment 17 Flos Lonicerae 2011-10-11 23:08:58 EDT
get it, thanks!
Comment 18 Fedora Update System 2011-10-14 16:17:34 EDT
parted-2.3-11.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/parted-2.3-11.fc15
Comment 19 Fedora Update System 2011-10-14 19:01:56 EDT
parted-2.3-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/parted-2.3-5.fc14
Comment 20 Fedora Update System 2011-10-15 16:28:21 EDT
Package parted-2.3-5.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing parted-2.3-5.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14410
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2011-10-15 20:56:35 EDT
parted-3.0-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Jim Meyering 2011-11-05 16:13:56 EDT
FYI, I applied that patch upstream and added a test:

http://thread.gmane.org/gmane.comp.gnu.parted.bugs/10535/focus=10594
Comment 23 Fedora Update System 2011-12-03 21:41:26 EST
parted-2.3-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Fedora Update System 2011-12-03 21:45:58 EST
parted-2.3-11.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.