Bug 714777 - Impossible to create OAuth access in josm
Summary: Impossible to create OAuth access in josm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: signpost-core
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cédric OLIVIER
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-20 16:59 UTC by Fabien Archambault
Modified: 2011-07-31 04:03 UTC (History)
2 users (show)

Fixed In Version: signpost-core-1.2.1.1-6.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-31 03:37:28 UTC


Attachments (Terms of Use)

Description Fabien Archambault 2011-06-20 16:59:45 UTC
Description of problem: when trying to create the OAuth key the software does nothing

Version-Release number of selected component (if applicable): josm-0-0.20.4064svn.fc15.noarch.rpm


How reproducible: always. It does not have the same behvior in F14 and F15...


Steps to Reproduce:
1. Try adding an OAuth account in preferences
2. In F15 a windows seem to blink
3. In F14 the Window says the password is wrong (I am sure as in direct connexion it works by copy paste) and then the application is frozen
  
Actual results: impossible to use OAuth


Additional info: For F15 it is a fresh install and in both cases it is the first time I install josm.

Comment 1 Cesar Eduardo Barros 2011-06-25 01:37:50 UTC
I just had the same problem (in F14, but with the symptoms you mentioned for F15). But I noticed the following in ~/.xsession-errors:

/usr/bin/build-classpath: error: Could not find commons-codec Java extension for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found

Sure enough, I solved the problem with the following command:

su -c 'yum install apache-commons-codec'

So, the cause of this bug seems to be a missing dependency on apache-commons-codec either on josm or on whatever oauth library it uses (it seems to be signpost-core).

Relevant packages:

josm-0-0.20.4064svn.fc14.noarch
signpost-core-1.2.1.1-4.fc14.noarch
apache-commons-codec-1.4-10.fc14.noarch
jpackage-utils-1.7.5-3.11.fc14.noarch

Comment 2 Fedora Update System 2011-06-28 18:49:18 UTC
signpost-core-1.2.1.1-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/signpost-core-1.2.1.1-6.fc15

Comment 3 Cédric OLIVIER 2011-06-28 18:53:58 UTC
As said by Cesar Eduardo Barros, it is a problem with signpost-core which requires apache-commons-codec.

Comment 4 Fedora Update System 2011-06-28 18:55:01 UTC
signpost-core-1.2.1.1-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/signpost-core-1.2.1.1-6.fc14

Comment 5 Fedora Update System 2011-06-29 21:57:16 UTC
Package signpost-core-1.2.1.1-6.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing signpost-core-1.2.1.1-6.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/signpost-core-1.2.1.1-6.fc15
then log in and leave karma (feedback).

Comment 6 Fabien Archambault 2011-07-11 13:22:16 UTC
Hi,

sorry to come back again but it does not work (I didn't have access to a Fedora computer until now).

I installed (fresh install) josm with :
# yum install josm
Dependencies Resolved

================================================================================
 Package                    Arch     Version                    Repository
                                                                           Size
================================================================================
Installing:
 josm                       noarch   0-0.20.4064svn.fc15        updates   5.9 M
Installing for dependencies:
 ant                        noarch   1.8.2-3.fc15               fedora    1.9 M
 java-1.6.0-openjdk-devel   x86_64   1:1.6.0.0-58.1.10.2.fc15   updates   8.3 M
 metadata-extractor         noarch   2.3.1-6.fc15               fedora    107 k
 signpost-core              noarch   1.2.1.1-5.fc15             fedora     34 k
 xalan-j2                   noarch   2.7.1-3.fc15               fedora    1.9 M
 xerces-j2                  noarch   2.11.0-3.fc15              fedora    1.1 M
 xml-commons-apis           noarch   1.4.01-3.fc15              fedora    224 k
 xml-commons-resolver       noarch   1.2-7.fc15                 fedora    106 k

Transaction Summary
================================================================================
Install       9 Package(s)


Updated with the updates-testing :
# yum update --enablerepo=updates-testing signpost-core-1.2.1.1-6.fc15
================================================================================
 Package                 Arch      Version             Repository          Size
================================================================================
Updating:
 signpost-core           noarch    1.2.1.1-6.fc15      updates-testing     34 k
Installing for dependencies:
 apache-commons-codec    noarch    1.4-12.fc15         fedora              69 k

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       1 Package(s)

Total download size: 103 k


Started josm then tried to add the OAuth for this computer. I checked the password again but still the same issue.
The error message is something like: impossible to access the token. Check username and password.

Here is the .xsessions_error:
org.openstreetmap.josm.gui.oauth.OsmLoginFailedException
	at org.openstreetmap.josm.gui.oauth.OsmOAuthAuthorizationClient.authenticateOsmSession(OsmOAuthAuthorizationClient.java:351)
	at org.openstreetmap.josm.gui.oauth.OsmOAuthAuthorizationClient.authorise(OsmOAuthAuthorizationClient.java:492)
	at org.openstreetmap.josm.gui.oauth.FullyAutomaticAuthorizationUI$FullyAutomaticAuthorisationTask.realRun(FullyAutomaticAuthorizationUI.java:534)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:83)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)


It does not really help...

Comment 7 Cédric OLIVIER 2011-07-11 16:47:43 UTC
Could you try with semi-automatic or manual method ?

Is it OK with josm-tested.jar downloaded from josm.openstreetmap.de in full automatic mode ?

Comment 8 Fabien Archambault 2011-07-12 09:21:03 UTC
Hi,

I tried with the semi-automatic mode and it works.
If I remove my .josm and use the josm-tested.jar (version 4223) the fully automatic version works to create the OAuth key.

Comment 9 Fedora Update System 2011-07-17 12:16:38 UTC
josm-0-0.21.4223svn.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/josm-0-0.21.4223svn.fc14

Comment 10 Fedora Update System 2011-07-17 12:18:09 UTC
josm-0-0.21.4223svn.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/josm-0-0.21.4223svn.fc15

Comment 11 Fedora Update System 2011-07-31 03:37:23 UTC
josm-0-0.21.4223svn.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-07-31 03:56:40 UTC
signpost-core-1.2.1.1-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-07-31 04:02:25 UTC
josm-0-0.21.4223svn.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2011-07-31 04:03:40 UTC
signpost-core-1.2.1.1-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.