Bug 714786 - Extended partition should map all unallocated disk space when MBR is full
Extended partition should map all unallocated disk space when MBR is full
Status: CLOSED DUPLICATE of bug 698429
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-20 14:32 EDT by Robert N. Evans
Modified: 2011-06-21 14:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
x86_64, BIOS, MBR
Last Closed: 2011-06-21 14:58:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert N. Evans 2011-06-20 14:32:35 EDT
Description of problem:
For some partition layouts it is impossible to allocate unused disk space after RHEL6 is installed.

Version-Release number of selected component (if applicable):
 anaconda-13.21.117-1.el6.x86_64

How reproducible:
 Deterministically, seems to happen every time


Steps to Reproduce:
1. Do kickstart install with a partitioning scheme that uses all 4 slots in the MBR but does not use all the available disk space.

2. Here is such a scheme:
clearpart --all --drives=sda,sdb --initlabel
part raid.1 --size=256 --asprimary --ondisk=sda
part raid.2 --size=256 --asprimary --ondisk=sdb
part raid.3 --size=16384 --asprimary --ondisk=sda
part raid.4 --size=16384 --asprimary --ondisk=sdb
part raid.5 --size=16384 --grow --maxsize=32768 --asprimary --ondisk=sda
part raid.6 --size=16384 --grow --maxsize=32768 --asprimary --ondisk=sdb
part raid.7 --size=4096 --ondisk=sda
part raid.8 --size=4096 --ondisk=sdb
raid /boot --fstype ext3 --level=RAID1 --device=md0 raid.1 raid.2
raid swap  --fstype swap --level=RAID1 --device=md1 raid.3 raid.4
raid /     --fstype ext3 --level=RAID1 --device=md2 raid.5 raid.6
raid /var/crash --fstype ext3 --level=RAID1 --device=md3 raid.7 raid.8

3. After install, attempt to create an additional partition.
  
Actual results:
Partition creation fails because there is no room in the MBR and although there is free disk space, the extended partition does not map that space.  It only maps the space necessary for the logical partition declared in the kickstart file.

Expected results:
The Extended partition would be large enough to contain the partition not declared --asprimary and also would contain all the free space on the disk.  Thus after installing RHEL, it would be possible to create additional logical partitions.  This is what occurred on RHEL5 with the same kickstart file.

Additional info:
It is somewhat inconvenient, but the Extended partition may be artificially inflated to use all the free space on the disk by adding an "extra" partition that may be later deleted.  (Although this only works if there is some additional space free on the disk)  For example:

part raid.10 --size=1 --grow --ondisk=sda
part raid.11 --size=1 --grow --ondisk=sdb
raid /extra --fstype ext3 --level=RAID1 --device=md4 --fsoptions="noauto" raid.1
0 raid.11


This bug seems to be a regression because the problem did not exist in RHEL5.
Comment 2 David Cantrell 2011-06-21 14:58:33 EDT

*** This bug has been marked as a duplicate of bug 698429 ***

Note You need to log in before you can comment on or make changes to this bug.