Bug 714817 - apache plugin: with some versions of JRockit 1.6 JVM, Apache server avail checks hang indefinitely when trying to HTTP-ping a server that's down
apache plugin: with some versions of JRockit 1.6 JVM, Apache server avail che...
Status: CLOSED DEFERRED
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.0.1
Unspecified Unspecified
medium Severity high (vote)
: ---
: ---
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks: jon3
  Show dependency treegraph
 
Reported: 2011-06-20 17:23 EDT by Ian Springer
Modified: 2013-08-05 20:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-22 16:44:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2011-06-20 17:23:24 EDT

    
Comment 1 Ian Springer 2011-06-21 15:05:02 EDT
[master 6002385] fixes this. The fix was to call setReadTimeout(1000) on the HTTP URL connection. It appears that for a non-responding URL, in the Sun JDK, the call to connect() would fail and so our setConnectTimeout(3000) sufficed, but, in the JRockit JDK, the call to connect() would succeed and then the call to getResponseCode() would hang because no read timeout was specified.

To test this, start an Agent with JRockit 1.6 and inventory an Apache server. Bring one or more of the Apache vhosts down then run the "discovery -f" and "avail" commands from the Agent prompt and make sure neither command hangs. Do the same with Agent on the Sun JVM to make sure it works there too.
Comment 2 Mike Foley 2011-06-22 16:44:56 EDT
not explicitly supported.  not going to verify this at this time.

Note You need to log in before you can comment on or make changes to this bug.