Bug 714826 - system-config-keyboard never applies changes
system-config-keyboard never applies changes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
15
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Itamar Reis Peixoto
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-20 18:27 EDT by Christoph Wickert
Modified: 2011-06-22 09:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-22 09:44:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2011-06-20 18:27:58 EDT
Description of problem:
system-config-keyboard is completely broken (at least) in F15 because it never applies any changes. There is no OK button or anything, so how is this supposed to work?

Version-Release number of selected component (if applicable):
system-config-keyboard-1.3.1-4.fc15

How reproducible:
always

Steps to Reproduce:
1. $ cat /etc/sysconfig/keyboard 
KEYTABLE="de-latin1-nodeadkeys"
MODEL="pc105"
LAYOUT="de"
KEYBOARDTYPE="pc"
VARIANT="nodeadkeys"

2. $ system-config-keyboard and switch keyboard
3. No OK button, so simply close the window
  
Actual results:
Nothing has changes
$ cat /etc/sysconfig/keyboard 
KEYTABLE="de-latin1-nodeadkeys"
MODEL="pc105"
LAYOUT="de"
KEYBOARDTYPE="pc"
VARIANT="nodeadkeys"

Expected results:
Another keyboard layout
Comment 1 Itamar Reis Peixoto 2011-06-20 18:42:03 EDT
try the newer version compiled by toshio.

http://koji.fedoraproject.org/koji/packageinfo?packageID=10


I think we probably need to change system-config-keyboard to noarch, but I dont have figured this yet.
Comment 2 Christoph Wickert 2011-06-20 18:53:47 EDT
Thanks, that fixes the problem.

Note You need to log in before you can comment on or make changes to this bug.