Bug 714855 - Failed to update memory info of "xm list -l" when memory resizing within PV guest
Summary: Failed to update memory info of "xm list -l" when memory resizing within PV g...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.7
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Miroslav Rezanina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-21 05:28 UTC by Yuyu Zhou
Modified: 2012-02-21 05:55 UTC (History)
4 users (show)

Fixed In Version: xen-3.0.3-133.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 05:55:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0160 normal SHIPPED_LIVE xen bug fix and enhancement update 2012-02-20 14:53:33 UTC

Description Yuyu Zhou 2011-06-21 05:28:33 UTC
Description of problem:
After memory resizing within PV guest via balloon, the "xm list -l" still shows the memory size before balloon

Version-Release number of selected component (if applicable):
xen-3.0.3-132.el5
rhel5 PV guest

How reproducible:
100%

Steps to Reproduce:

1. Start a RHEL5 PV guest, and read from /proc/xen/balloon in guest.
[guest]# cat /proc/xen/balloon
current allocation:  1048576 kB
Requested target:    1048576 kB
Low-mem balloon:        8192 kB
High-mem balloon:          0 kB
Driver pages:              0 kB
Xen hard limit:          ??? kB

2.Lower memory size of PV guest via balloon. In the guest:
[guest]# echo 512M > /proc/xen/balloon
[guest]# cat /proc/xen/balloon
Current allocation:   524288 kB
Requested target:     524288 kB
Low-mem balloon:      532480 kB
High-mem balloon:          0 kB
Driver pages:              0 kB
Xen hard limit:          ??? kB
[guest]# free -m
             total       used       free     shared    buffers     cached
Mem:           512        322        189          0         15        161
-/+ buffers/cache:        145        366
Swap:          588          0        588

3. Check memory size of PV guest externally.
[host]# xm list
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     3779     4 r-----   1924.2
RHEL5.7-64-PV                             47      512     4 -b----     11.3
[host]# xm list -l 47| grep mem
    (memory 1024)
    (shadow_memory 0)
    (maxmem 1024)

  
Actual results:
The memory info from "xm list -l" still remains 1024

Expected results:
The memory info from "xm list -l" should change to 512.

Additional info:
Also can be reproduced on xen-3.0.3-120.el5
The guest mem-set from Domain0 works well.

Comment 1 Miroslav Rezanina 2011-06-21 06:31:21 UTC
Problem is that xm list -l does not update memory field to current value as short version do.

Comment 6 Qixiang Wan 2011-12-05 06:59:48 UTC
Verified with xen-3.0.3-135.el5. After the fix, 'xm list -l' can show correct changed memory value.

Steps:
1. Boot up a RHEL5u7 i386 PV guest with memory=1024 and maxmem=1024
2. Balloon down memory within the guest.
   # echo 512M > /proc/xen/balloon
3. Check guest memory in Dom0.
   # rpm -q xen
   xen-3.0.3-135.el5
   # xm list rhel
   Name                                      ID Mem(MiB) VCPUs State   Time(s)
   rhel                                       2      512     1 -b----     16.1
   # xm list -l rhel | grep mem
      (memory 512)
      (shadow_memory 0)
      (maxmem 1024)

Comment 7 errata-xmlrpc 2012-02-21 05:55:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0160.html


Note You need to log in before you can comment on or make changes to this bug.