Bug 714880 - etherboot-zroms-kvm should depend on chkconfig
etherboot-zroms-kvm should depend on chkconfig
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: etherboot (Show other bugs)
5.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2011-06-21 03:58 EDT by Jan Stodola
Modified: 2013-04-12 16:53 EDT (History)
8 users (show)

See Also:
Fixed In Version: etherboot-5.4.4-16.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:28:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2011-06-21 03:58:11 EDT
Description of problem:
etherboot-zroms-kvm runs '/usr/sbin/update-alternatives' in its installation scriplet, but the package doesn't depend on chkconfig:

[root@ibm-hs21-12 test_rpms]# rpm -q --scripts -p rpms/etherboot-zroms-kvm-5.4.4-15.el5.x86_64.rpm 
postinstall scriptlet (using /bin/sh):
/usr/sbin/update-alternatives --install /usr/share/qemu-pxe-roms \
  qemu-pxe-roms /usr/share/etherboot 20
postuninstall scriptlet (using /bin/sh):
if [ $1 -eq 0 ] ; then
  /usr/sbin/update-alternatives --remove qemu-pxe-roms /usr/share/etherboot
fi
[root@ibm-hs21-12 test_rpms]# rpm -qf /usr/sbin/update-alternatives
chkconfig-1.3.30.2-2.el5
[root@ibm-hs21-12 test_rpms]# rpm -q --requires -p rpms/etherboot-zroms-kvm-5.4.4-15.el5.x86_64.rpm 
/bin/sh  
/bin/sh  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
[root@ibm-hs21-12 test_rpms]#


It causes error messages in some cases:
...
  Installing     : libtermcap                                              9/12 
  Installing     : mktemp                                                 10/12 
  Installing     : bash                                                   11/12 
  Installing     : etherboot-zroms-kvm                                    12/12
/var/tmp/rpm-tmp.71424: line 1: /usr/sbin/update-alternatives: No such file or directory
error: %post(etherboot-zroms-kvm-5.4.4-15.el5.x86_64) scriptlet failed, exit status 127

Version-Release number of selected component (if applicable):
etherboot-zroms-kvm-5.4.4-15.el5

How reproducible:
always

Steps to Reproduce:
1. yum --installroot=/root/new_install_root install etherboot-zroms-kvm

Actual results:
errors during installation

Expected results:
etherboot-zroms-kvm depends on chkconfig, no error messages during installation
Comment 1 Ronen Hod 2011-07-31 03:06:10 EDT
Dev ack since Eduardo says that it is trivial
Comment 2 RHEL Product and Program Management 2011-09-22 20:24:52 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-06-11 21:00:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 Sibiao Luo 2012-07-03 05:53:32 EDT
I reproduce and verify this issue on the kvm-83-254.el5 with the following steps.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q kvm
2.6.18-322.el5
kvm-83-254.el5

reproduce steps and results:
1.make sure the host has no install the chkconfig package.
# rpm -qa | grep chkconfig
2.install the etherboot-zroms-kvm-5.4.4-13.el5.
# rpm -ivh etherboot-zroms-kvm-5.4.4-13.el5.x86_64.rpm
Preparing...                ########################################### [100%]
   1:etherboot-zroms-kvm    ########################################### [100%]
/var/tmp/rpm-tmp.12877: line 1: /usr/sbin/update-alternatives: No such file or directory
error: %post(etherboot-zroms-kvm-5.4.4-13.el5.x86_64) scriptlet failed, exit status 127

verify steps and results:
1.make sure the host has no install the chkconfig package.
# rpm -qa | grep chkconfig
2.install the etherboot-zroms-kvm-5.4.4-16.el5.
# rpm -ivh etherboot-zroms-kvm-5.4.4-16.el5.x86_64.rpm
error: Failed dependencies:
	/usr/sbin/update-alternatives is needed by etherboot-zroms-kvm-5.4.4-16.el5.x86_64

Additional test:
I also make the additional test, firt of all make sure the host has installed the chkconfig patch, then erase the chkconfig patch, it fail and prompt with error: Failed dependencies (/usr/sbin/update-alternatives).
# rpm -e chkconfig-1.3.30.2-2.el5
error: Failed dependencies:
...
	/usr/sbin/alternatives is needed by (installed) cups-1.3.7-30.el5.x86_64
	/usr/sbin/alternatives is needed by (installed) sendmail-8.13.8-8.1.el5_7.x86_64
	/usr/sbin/alternatives is needed by (installed) emacs-common-21.4-24.el5.x86_64
	/usr/sbin/alternatives is needed by (installed) im-chooser-0.3.3-6.el5.x86_64
	/usr/sbin/update-alternatives is needed by (installed) java-1.4.2-gcj-compat-1.4.2.0-40jpp.115.x86_64
	/usr/sbin/update-alternatives is needed by (installed) antlr-2.7.6-4jpp.2.x86_64
	/usr/sbin/update-alternatives is needed by (installed) gpxe-roms-qemu-0.9.7-9.el5.x86_64
	/usr/sbin/update-alternatives is needed by (installed) etherboot-zroms-kvm-5.4.4-16.el5.x86_64

Base on above, this issue has been fixed correctly.
Comment 13 errata-xmlrpc 2013-01-08 02:28:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0056.html

Note You need to log in before you can comment on or make changes to this bug.