Bug 714882 - gpxe-roms-qemu should depend on chkconfig
gpxe-roms-qemu should depend on chkconfig
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gpxe (Show other bugs)
5.6
All Linux
low Severity low
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2011-06-21 04:07 EDT by Jan Stodola
Modified: 2013-04-12 16:53 EDT (History)
8 users (show)

See Also:
Fixed In Version: gpxe-0.9.7-9.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:28:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2011-06-21 04:07:11 EDT
Description of problem:
gpxe-roms-qemu runs '/usr/sbin/update-alternatives' in its installation
scriplet, but the package doesn't depend on chkconfig:

[root@ibm-hs21-12 test_rpms]# rpm -q --scripts -p rpms/gpxe-roms-qemu-0.9.7-8.el5.x86_64.rpm 
postinstall scriptlet (using /bin/sh):
/usr/sbin/update-alternatives --install /usr/share/qemu-pxe-roms \
  qemu-pxe-roms /usr/share/gpxe 10
postuninstall scriptlet (using /bin/sh):
if [ $1 -eq 0 ] ; then
  /usr/sbin/update-alternatives --remove qemu-pxe-roms /usr/share/gpxe
fi


# %ifarch i386 i486 i586 i686 pentium3 pentium4 athlon geode x86_64
[root@ibm-hs21-12 test_rpms]# rpm -qf /usr/sbin/update-alternatives
chkconfig-1.3.30.2-2.el5
[root@ibm-hs21-12 test_rpms]# rpm -q --requires -p rpms/gpxe-roms-qemu-0.9.7-8.el5.x86_64.rpm 
/bin/sh  
/bin/sh  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
[root@ibm-hs21-12 test_rpms]#


It causes error messages in some cases:
...
  Installing     : libtermcap                                              9/12 
  Installing     : mktemp                                                 10/12 
  Installing     : bash                                                   11/12 
  Installing     : gpxe-roms-qemu                                         12/12
/var/tmp/rpm-tmp.47728: line 1: /usr/sbin/update-alternatives: No such file or directory

error: %post(gpxe-roms-qemu-0.9.7-8.el5.x86_64) scriptlet failed, exit status 127


Version-Release number of selected component (if applicable):
gpxe-roms-qemu-0.9.7-8.el5

How reproducible:
always

Steps to Reproduce:
1. yum --installroot=/root/new_install_root install gpxe-roms-qemu

Actual results:
errors during installation

Expected results:
gpxe-roms-qemu depends on chkconfig, no error messages during installation
Comment 1 Ronen Hod 2011-07-31 09:56:18 EDT
Eduardo said that it is a trivial fix. Devel_ack+
Comment 3 RHEL Product and Program Management 2011-09-22 20:15:23 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-06-11 21:00:01 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 11 langfang 2012-07-03 07:44:59 EDT
I reproduce and verify this issue on the kvm-83-249.el5 with the following steps.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q kvm
2.6.18-322.el5
kvm-83-254.el5


reproduce steps and results:
1.make sure the host has no install the chkconfig package.
# rpm -qa | grep chkconfig

2.yum --installroot=/root/new_install_root install gpxe-roms-qemu

results:
...
  Installing     : libtermcap                                              9/12 
  Installing     : mktemp                                                 10/12 
  Installing     : bash                                                   11/12 
  Installing     : gpxe-roms-qemu                                         12/12
/var/tmp/rpm-tmp.73320: line 1: /usr/sbin/update-alternatives: No such file or directory
Non-fatal POSTIN scriptlet failure in rpm package gpxe-roms-qemu-0.9.7-8.el5.x86_64
error: %post(gpxe-roms-qemu-0.9.7-8.el5.x86_64) scriptlet failed, exit status 127
Installed products updated.

verify steps and results:
1.make sure the host has no install the chkconfig package.
# rpm -qa | grep chkconfig
2.install the gpxe-roms-qemu-0.9.7-9.el5.x86_64.rpm
# rpm -ivh gpxe-roms-qemu-0.9.7-9.el5.x86_64.rpm
error: Failed dependencies:

/usr/sbin/update-alternatives is needed by gpxe-roms-qemu-0.9.7-9.el5.x86_64


follow above ,this bug is fixed.
Comment 14 errata-xmlrpc 2013-01-08 02:28:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0057.html

Note You need to log in before you can comment on or make changes to this bug.