This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 714910 - lv_swap create failed after live migration when guest installation is formatting virtual disks
lv_swap create failed after live migration when guest installation is formatt...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-06-21 05:43 EDT by FuXiangChun
Modified: 2013-01-09 19:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-13 05:14:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
destination host snapshot (19.31 KB, image/png)
2011-06-21 05:43 EDT, FuXiangChun
no flags Details
destination host snapshot2 (19.04 KB, image/png)
2011-06-21 05:46 EDT, FuXiangChun
no flags Details
source host snapshot (8.97 KB, image/png)
2011-06-21 05:46 EDT, FuXiangChun
no flags Details

  None (edit)
Description FuXiangChun 2011-06-21 05:43:33 EDT
Created attachment 505785 [details]
destination host snapshot

Description of problem:
do live migrate when guest installation is formatting virtual disks.
after migration, guest create lv_swap failed. 

there are three snapshot files in attachment.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1./usr/libexec/qemu-kvm -M rhel5.6.0 -m 4096 -smp 4,sockets=4,cores=1,threads=1 -name RHEL5u7 -uuid 13bd47ff-7458-a214-9c43-d311ed5ca5a3 -monitor stdio -no-kvm-pit-reinjection -boot nc -drive file=/dev/vg0/data2,if=virtio,format=qcow2,cache=none,boot=on -net nic,macaddr=54:52:00:52:ed:62,vlan=0,model=e1000 -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -vnc :1 -balloon none -notify all -no-hpet -soundhw ac97 -kernel /mnt/vmlinuz -initrd /mnt/initrd.img -append method=http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL6.1-20110510.1/6.1/Server/x86_64/os

2./usr/libexec/qemu-kvm -M rhel5.6.0 -m 4096 -smp 4,sockets=4,cores=1,threads=1 -name RHEL5u7 -uuid 13bd47ff-7458-a214-9c43-d311ed5ca5a3 -monitor stdio -no-kvm-pit-reinjection -boot nc -drive file=/dev/vg0/data2,if=virtio,format=qcow2,cache=none,boot=on -net nic,macaddr=54:52:00:52:ed:62,vlan=0,model=e1000 -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -vnc :1 -balloon none -notify all -no-hpet -soundhw ac97 -kernel /mnt/vmlinuz -initrd /mnt/initrd.img -append method=http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL6.1-20110510.1/6.1/Server/x86_64/os -incoming tcp:0:5555

3.when formatting virtual disk, do migrate
  migrate -d tcp:xxx:5555

4. migrate_set_downtime 3s and migrate_set_speed 1G

  
Actual results:


Expected results:


Additional info:
Comment 1 FuXiangChun 2011-06-21 05:46:00 EDT
Created attachment 505786 [details]
destination host snapshot2
Comment 2 FuXiangChun 2011-06-21 05:46:48 EDT
Created attachment 505787 [details]
source host snapshot
Comment 3 Dor Laor 2011-08-07 06:32:13 EDT
Does this reproduces each time?
Does it happens with IDE instead of virtio?
Comment 4 FuXiangChun 2011-08-08 06:41:16 EDT
Hi Dor
   
   I tried many times testing but still cann't reproduce this bug via above steps now.  IDE and virtio are tested.
Comment 5 Ronen Hod 2011-10-11 10:12:44 EDT
Well, if it cannot be reproduced then I suggest that we close this bug.
Comment 6 FuXiangChun 2011-10-12 06:50:54 EDT
Ronen,

   I am finding machines. I plan to try last times again and update bz tomorrow.
Comment 7 FuXiangChun 2011-10-13 05:14:34 EDT
since bug cann't be reproduced. so i closed it.
Comment 8 Ronen Hod 2011-10-15 14:59:04 EDT
Thanks!

Note You need to log in before you can comment on or make changes to this bug.