Bug 714915 - BSOD occurs in windows guest when hit werror wi/o werror=stop
BSOD occurs in windows guest when hit werror wi/o werror=stop
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Arkady Frenkel
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-06-21 06:19 EDT by Mike Cao
Modified: 2011-07-06 08:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-06 05:38:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen dump (20.52 KB, image/png)
2011-06-21 06:20 EDT, Mike Cao
no flags Details

  None (edit)
Description Mike Cao 2011-06-21 06:19:28 EDT
Description of problem:

Version-Release number of selected component (if applicable):
# uname -r
2.6.18-267.el5
# rpm -q kvm
kvm-83-236.el5

guestinfo :
windows 2008 

How reproducible:
3/3

Steps to Reproduce:
1.prepare a iscsi-server.
2.use iscsi-initiator to connected it and create a image on it 
#qemu-img create -f raw /dev/mike_cao/win08_5.6.0 20G
3.start guest w/o werror=stop
eg:/usr/libexec/qemu-kvm -m 4G -smp 1,sockets=1,cores=1,threads=1 -name RHEL5u7 -uuid 13bd47ff-7458-a214-9c43-d311ed5ca5a3 -monitor stdio -no-kvm-pit-reinjection -boot c -drive file=/dev/mike_cao/win08_5.6.0,if=ide,format=raw,cache=none,boot=on -net nic,macaddr=54:52:00:52:ed:61,vlan=0,model=rtl8139 -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -serial pty -parallel none -usb -vnc :7 -k en-us -vga cirrus -balloon none -notify all
4.in the guest #ping 8.8.8.8 -t
5.stop iscsi target server 
  
Actual results:
after 2-3 mins ,BSOD happend in the guest (referring to the screendump)
(qemu)bdrv_write ret=-5

Expected results
no BOSD occurs

Additional info:
Comment 1 Mike Cao 2011-06-21 06:20:10 EDT
Created attachment 505793 [details]
Screen dump
Comment 4 Arkady Frenkel 2011-07-03 05:02:57 EDT
Hi, Mike!
Please upload memory dump file of that crash ( screen dump is just some part of it). That may be memory.dmp file in windows directory or kernel minidump file in windows\minidump directory. Obviously kernel dump include more info than minidump but let's start from something we have. If minidump will have no enough info, I'll ask you to set 
"kernel memory dump" in advance options in the property box of the computer and reproduce the crash
TIA
Arkady
Comment 5 Arkady Frenkel 2011-07-03 10:51:54 EDT
Hi, Mike!
After some additional analysis ( just didn't pay attention on the bottom  of the bluescreen, I understand that it's impossible to receive dump file because of disk absence. But that was the reason why bsod happen, some critical process ( the one from the list in http://msdn.microsoft.com/en-us/library/aa373646%28VS.85%29.aspx ) tried to write to disk ( e.g. paged memory into swapfile or something else ) and failed on that write op. That caused for this process to terminated and in advance caused current BSOD - CRITICAL_OBJECT_TERMINATION (f4)
A process or thread crucial to system operation has unexpectedly exited or been
terminated.  
When werror=stop exist qemu suspend VM so windows kernel doesn't run and no write error happen in it. When you restart iscsi-target (insert disk back) the guest continue to work without knowledge of the previous write error.
So for the windows guest werror=stop is must, unless you want to remove it for some debug purposes.

Arkady
Comment 6 Ronen Hod 2011-07-04 05:54:12 EDT
Mike, Arkady,
I believe that we would like the default to be werror=stop.
Anyhow, we try to do the bare minimum for RHEL-5. How are things with RHEL-6.1
Comment 7 Mike Cao 2011-07-04 06:15:48 EDT
(In reply to comment #6)
> Mike, Arkady,
> I believe that we would like the default to be werror=stop.
no ,Kevin said Default value is werror=enospc

> Anyhow, we try to do the bare minimum for RHEL-5. How are things with RHEL-6.1
Comment 8 Arkady Frenkel 2011-07-04 08:29:48 EDT
In this case, if we'll decide not to change to default werror=stop for guest running windows OS (any) in RHEL 6, possible to stand that it's by design behaviour, as I wrote before.
Comment 9 Ronen Hod 2011-07-06 05:38:41 EDT
Closing the bug.
BSOD is the expected guest behavior when its system disk is suddenly removed.
Comment 10 Mike Cao 2011-07-06 05:51:22 EDT
(In reply to comment #9)
> Closing the bug.
> BSOD is the expected guest behavior when its system disk is suddenly removed.


as werror=stop is the recommend param during testing .Can we change to default werror=stop ?

Mike
Comment 11 Arkady Frenkel 2011-07-06 07:14:38 EDT
At least for VM running Windows.
Comment 12 Ronen Hod 2011-07-06 08:20:21 EDT
Kevin,

In view of https://bugzilla.redhat.com/show_bug.cgi?id=714915#c7

What is your call?

Note You need to log in before you can comment on or make changes to this bug.