Bug 71497 - Incorrect behavior with From field.
Summary: Incorrect behavior with From field.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mailx (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jiri Ryska
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-14 12:53 UTC by Leonid Mamtchenkov
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 08:18:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leonid Mamtchenkov 2002-08-14 12:53:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
When sending mail with /bin/mail, it takes user's real name from /etc/passwd and
includes it in From field.  Parsing of the real name is broken, since real name
field in /etc/passwd can contain additional information, like office and office
phone (fill all fields using chfn).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.chfn someuser
2.fill all fields
3.su - someuser
4.mail someotheruser
5.check email from someotheruser
	

Actual Results:  From field looks like this:
From: "John Doe,Redhat Inc.,+123 1 1234567,123 1 1234568" <john_doe@redhat.com>

Expected Results:  From: "John Doe" <john_doe@redhat.com>

Additional info:

Comment 1 Ivana Varekova 2004-11-02 08:18:56 UTC
Thank you for your notice.
This problem does not occure in version mailx-8.1.1-33.
IV


Note You need to log in before you can comment on or make changes to this bug.