This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 71501 - Not all packages present in flat view
Not all packages present in flat view
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-14 09:51 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-04 16:46:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-14 09:51:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
In version 7.2 selecting flat view when installing packages provided the list 
of ALL packages. 7.3 limits this just to those packages that it thinks are 
selectable (no selection for i.e. sendmail)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run installer
2. Select Custom Setup
3. Choose Select Individual Packages
4. Select Flat View 

Actual Results:  The list of the packages already accessible through Tree View

Expected Results:  ALL packages

Additional info:

Is there a workaround? Except uninstalling unneeded packages after installation?
Comment 1 Michael Fulbright 2002-08-14 14:48:22 EDT
Packages required by the base install are not shown.

We should probably show them and not let them be unselected, but show them as
selected.
Comment 2 Need Real Name 2002-08-14 15:17:59 EDT
I do understand that you have to support users that might want to install Red 
Hat, but still to unselect kernel because it is large. However I think that the 
right approach would be to display all these packages, still allow users to 
disable them, but show a warning pop-up.
In my view there are quite a few packages in this "standard" portion that I 
would leave out of, say, firewall, and not allowing me to disselect them 
reminds me too much of Windows where you end up installing Minesweeper and 
Solitaire whether you like it or not.
Comment 3 Jeremy Katz 2003-03-04 16:46:40 EST
We now allow selection of everything that isn't going to cause a critical
problem if you don't install it.  Which cuts things down quite  abit more.  

Note You need to log in before you can comment on or make changes to this bug.