This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 715072 - Rebase request for crash utility RHEL5.8 errata
Rebase request for crash utility RHEL5.8 errata
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: crash (Show other bugs)
5.8
All Linux
high Severity high
: rc
: ---
Assigned To: Dave Anderson
Han Pingtian
: Rebase
Depends On:
Blocks: 57KnownIssue
  Show dependency treegraph
 
Reported: 2011-06-21 15:20 EDT by Dave Anderson
Modified: 2012-02-21 00:52 EST (History)
2 users (show)

See Also:
Fixed In Version: crash-5.1.8-1.el5
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump, kdump and virsh dump facilities. With this update, Crash has been rebased to upstream version 5.1.8. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:52:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Anderson 2011-06-21 15:20:10 EDT
Description of problem:

The RHEL5.8 errata version of crash is long overdue for a rebase to the
upstream version of the crash utility.

It is far more efficient, and far safer, to rebase to the upstream 
version than to attempt to selectively backport the patches required for
the current set of bugzillas requested for RHEL5.8.  Furthermore, the new
features and other fixes that have been applied to the upstream version 
make the tool significantly more useful than the current RHEL5 version.
And although the RHEL5 version of the crash utility by definition is for
support of RHEL5 kernels, since the introduction of KVM for RHEL5, it
is very possible that there may be RHEL6 guest dumpfiles taken with
"virsh dump" on a RHEL5 KVM host, and those dumpfiles are physically
located on the RHEL5 KVM host machine.  Therefore a much more recent
crash version that the very old 4.1.2 base would be required.

As the owner and upstream maintainer, one of my primary goals is, and
always has been, to maintain backwards-compatibility whenever new fixes
or features are applied.  Therefore the risk of regression is less with a
rebase than it would be with selective backports because the RHEL5.8
bugzilla-requested fixes are based upon the state of the upstream version. 

It should be noted that nothing goes into the upstream version without
my approval, and my testing.  I perform all my testing against a sample
set of RHEL3, RHEL4, RHEL5, RHEL6, upstream and Fedora kernel crash dumps.

Details regarding recent fixes, features and enhancements can be found in:

  http://people.redhat.com/anderson/crash.changelog.html


Version-Release number of selected component (if applicable):

crash-4.1.2-8.el5
the upstream version of crash is now at crash-5.1.6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Dave Anderson 2011-06-21 15:48:57 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump, kdump
and virsh dump facilities.

With this update, Crash has been rebased to upstream version 5.1.x. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html
Comment 5 Dave Anderson 2011-06-29 09:00:09 EDT
> And although the RHEL5 version of the crash utility by definition is for
> support of RHEL5 kernels, since the introduction of KVM for RHEL5, it
> is very possible that there may be RHEL6 guest dumpfiles taken with
> "virsh dump" on a RHEL5 KVM host, and those dumpfiles are physically
> located on the RHEL5 KVM host machine.  Therefore a much more recent
> crash version that the very old 4.1.2 base would be required.

Han Pingtian posted an example of this situation in another BZ:

  https://bugzilla.redhat.com/show_bug.cgi?id=716327#c6
  https://bugzilla.redhat.com/show_bug.cgi?id=716327#c7
Comment 6 Han Pingtian 2011-06-29 21:57:02 EDT
According to Dave's suggestion, I copying the comments here:

I just notice that 6.1 Xen HVM guest vmcore get by Xen's auto-dump-when-crashed
function also cannot be analysed by 5.7's crash, but can be analysed by 6.1's:

[root@hp-bl495cg5-02 ~]# crash vmlinux
/var/lib/xen/dump/2011-0629-0054.42-rhel61_x86_64_hvm.2.core

crash 4.1.2-8.el5
Copyright (C) 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009  Red Hat, Inc.
Copyright (C) 2004, 2005, 2006  IBM Corporation
Copyright (C) 1999-2006  Hewlett-Packard Co
Copyright (C) 2005, 2006  Fujitsu Limited
Copyright (C) 2006, 2007  VA Linux Systems Japan K.K.
Copyright (C) 2005  NEC Corporation
Copyright (C) 1999, 2002, 2007  Silicon Graphics, Inc.
Copyright (C) 1999, 2000, 2001, 2002  Mission Critical Linux, Inc.
This program is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions.  Enter "help copying" to see the conditions.
This program has absolutely no warranty.  Enter "help warranty" for details.

GNU gdb 6.1
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu"...

crash: invalid kernel virtual address: 373b415bf39e96dd  type: "possible"
WARNING: cannot read cpu_possible_map
crash: invalid kernel virtual address: ed01608e81bf816c  type: "present"
WARNING: cannot read cpu_present_map
crash: invalid kernel virtual address: 500e81dd485d03c1  type: "online"
WARNING: cannot read cpu_online_map
crash: cannot determine base kernel version
crash: vmlinux and /var/lib/xen/dump/2011-0629-0054.42-rhel61_x86_64_hvm.2.core
do not match!

Usage:
  crash [-h [opt]][-v][-s][-i file][-d num] [-S] [mapfile] [namelist]
[dumpfile]

Enter "crash -h" for details.
Comment 8 Dave Anderson 2011-10-04 11:14:07 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1,4 @@
 The crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump, kdump
 and virsh dump facilities.
 
-With this update, Crash has been rebased to upstream version 5.1.x. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html+With this update, Crash has been rebased to upstream version 5.1.8. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html
Comment 11 errata-xmlrpc 2012-02-21 00:52:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0203.html

Note You need to log in before you can comment on or make changes to this bug.