Bug 715107 - fence_vmware_soap -o list doesn't expose proper virtual machine path for fencing.
fence_vmware_soap -o list doesn't expose proper virtual machine path for fenc...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.7
All Other
medium Severity medium
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks: 771211 772956
  Show dependency treegraph
 
Reported: 2011-06-21 17:24 EDT by Toure Dunnon
Modified: 2012-04-24 11:05 EDT (History)
7 users (show)

See Also:
Fixed In Version: cman-2.0.115-95.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 771211 (view as bug list)
Environment:
Last Closed: 2012-02-21 00:24:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 62221 None None None Never

  None (edit)
Description Toure Dunnon 2011-06-21 17:24:23 EDT
Description of problem:

when using fence_vmware_soap to list node/virt-guest it doesn't expose the full path which is needed to fence the device. I know that this is late to the game in getting this accepted, so I did add a comment into the document bug to make sure customers are aware of the pathname which is need to fence the node. 
 

Version-Release number of selected component (if applicable):



Actual results:
[root@kvm-node1 ~]# fence_vmware_soap -o list -a rhha-vcenter.lab.eng.rdu.redhat.com -l Administrator -p Redhat01 -z


Vcenter,564d518e-375f-4c9b-8936-09039f7d72eb
RHEL57_MAY_06_03,564ddee8-f917-b410-0fa8-70d18c17b679
RHEL57_MAY_06_02,564d00eb-156d-740d-c0ad-a8abf21d253d
RHEL57_MAY_06_01,564d85d0-e22e-4661-8073-cbb3edc075d7

Expected results:

[root@kvm-node1 ~]# fence_vmware_soap -o list -a rhha-vcenter.lab.eng.rdu.redhat.com -l Administrator -p Redhat01 -z

Vcenter,564d518e-375f-4c9b-8936-09039f7d72eb
/RHHA_QA/vm/RHEL57_MAY_06_03,564ddee8-f917-b410-0fa8-70d18c17b679
/RHHA_QA/vm/RHEL57_MAY_06_02,564d00eb-156d-740d-c0ad-a8abf21d253d
/RHHA_QA/vm/RHEL57_MAY_06_01,564d85d0-e22e-4661-8073-cbb3edc075d7

or something like that, the managed object looks to contain this path information through the following:

Managed Object - Datacenter
Managed Object - Folder
Comment 6 Marek Grac 2011-12-09 04:14:12 EST
Users can now use names obtained via 'list' option (if they are unique)

Patch is now part of upstream:

http://git.fedorahosted.org/git/?p=fence-agents.git;a=commit;h=db314d3957b2c17b6e3bcc035f2738b771631bdd
Comment 10 errata-xmlrpc 2012-02-21 00:24:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0167.html

Note You need to log in before you can comment on or make changes to this bug.