Bug 71512 - Milan Beta4: up kernel hangs system w/e1000 plugged in
Milan Beta4: up kernel hangs system w/e1000 plugged in
Status: CLOSED DUPLICATE of bug 71449
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-14 12:24 EDT by Jeff Needle
Modified: 2007-04-18 12:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 12:26:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (7.64 KB, text/plain)
2002-08-14 12:26 EDT, Jeff Needle
no flags Details

  None (edit)
Description Jeff Needle 2002-08-14 12:24:49 EDT
On a system running Milan Beta4's uniprocessor kernel, the machine locks
bringing up the interface for an e1000 card adapter only when the cable is
plugged in.  
Adapters tested: copper gigabit (82544E1 chipset) and fiber gigabit (82543GC). 

Bug does not exist on RHL 7.3 or Milan beta 3.  Tested with different adapters,
slots, and systems.

Procedure for locking the machine after logging in:
# these first 3 commands are optional, but make it clear that no other network
devices are interfering

echo 0 > /proc/sys/kernel/hotplug    # turn off hotplug so loading e1000.o will
not cause eepro100.o to be loaded
rmmod eepro100                       # go ahead and get the e100 devices out of
the picture
modprobe e1000                       # load driver

# be sure the network cable is unplugged.  now a test run, just for kicks:
ifconfig eth0 x.x.x.x netmask x.x.x.x             # does _not_ cause a hang
ifconfig eth0 down

# now plug in the network cable
ifconfig eth0 x.x.x.x netmask x.x.x.x

#machine is now hard locked

----------
Action by: wendyh
Issue Registered
----------
Action by: wendyh
lspci output attached.

Status set to: Waiting on Tech
Attachment: <a href="?module=download&fid=770">lspci.txt</a>
Comment 1 Jeff Needle 2002-08-14 12:26:29 EDT
Created attachment 70624 [details]
lspci output
Comment 2 Arjan van de Ven 2002-08-14 12:29:40 EDT

*** This bug has been marked as a duplicate of 71449 ***

Note You need to log in before you can comment on or make changes to this bug.