Bug 71522 - Enh: have scripts check to see if kernel-source rpm is installed
Enh: have scripts check to see if kernel-source rpm is installed
Status: CLOSED NOTABUG
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: kernel (Show other bugs)
1.7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Kloiber
Chris Kloiber
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-14 14:31 EDT by Glen A. Foster
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 14:31:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen A. Foster 2002-08-14 14:31:40 EDT
Description of Problem: It would aid/assist troubleshooting of the RHR scripts
if, when looking for /usr/src/linux (or /usr/src/linux-2.4), the function
locate_sources() in /etc/init.d/rhr_functions were patched as follows:

# diff -u rhr_functions.ORIG rhr_functions
--- rhr_functions.ORIG  2002-08-14 12:28:57.000000000 -0600
+++ rhr_functions       2002-08-14 12:31:48.000000000 -0600
@@ -314,7 +314,12 @@
                SOURCEDIR="/usr/src/linux-2.4"
                echo -n "Located 2.4 kernel source tree..."
        else
-               action "Could not locate source tree." /bin/false
+               rpm -q kernel-source > /dev/null 2>&1
+               if [ $? -ne 0 ]; then
+                       action "No kernel-source rpm installed" /bin/false
+               else
+                       action "Could not locate source tree." /bin/false
+               fi
                exit 1
        fi
}

Version-Release number of selected component (if applicable):
# rpm -qf /etc/init.d/rhr_functions
rhr-core-1.7-10d
Comment 1 Chris Kloiber 2002-08-16 22:36:00 EDT
One of the requirements for running the Red Hat Ready Certification tests is an
"Everything" class install. This means kernel-source is assumed to be present.
While adding a check for kernel-source would not hurt, it is not really needed.
Comment 2 Glen A. Foster 2002-08-19 11:47:14 EDT
... of course, it's not needed, which is why the summary started as "Enh:"  
(enhancement).  Since enhancements are typically requests, can you re-close 
this bug as WONTFIX instead of NOTABUG, please?

Note You need to log in before you can comment on or make changes to this bug.