Bug 715237 - Core dump occurs when doing dd in the guest
Core dump occurs when doing dd in the guest
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-06-22 06:31 EDT by FuXiangChun
Modified: 2011-07-29 03:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-29 03:59:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (10.24 KB, application/octet-stream)
2011-06-22 06:40 EDT, FuXiangChun
no flags Details

  None (edit)
Description FuXiangChun 2011-06-22 06:31:19 EDT
Description of problem:
as subject, this is error message in monitor.
(qemu) qemu-kvm: block-qcow2.c:1621: qcow_aio_write_cb: Assertion `(acb->cluster_offset & 511) == 0' failed.
Aborted (core dumped)

backtrace file is in attachment.

Version-Release number of selected component (if applicable):
host info:
# uname -r
2.6.18-268.el5
#rpm -qa|grep kvm
kvm-83-237.el5

guest info:
RHEL6.1_64

How reproducible:


Steps to Reproduce:
1./usr/libexec/qemu-kvm -M rhel5.6.0 -m 4096 -smp 4,sockets=4,cores=1,threads=1 -name RHEL5u7 -uuid 13bd47ff-7458-a214-9c43-d311ed5ca5a3 -monitor stdio -no-kvm-pit-reinjection -boot c -drive file=/dev/vg0/data1,if=virtio,format=qcow2,cache=none,boot=on,werror=stop -net nic,macaddr=54:52:00:52:ed:62,vlan=0,model=e1000 -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -vnc :1 -balloon none -notify all -no-hpet -soundhw ac97

2.run below script in guest
for ((;;))
do
dd if=/dev/zero of=test1 bs=1M count=10000
done

3. after several minutes, monitor will show below core dumped message.
(qemu) qemu-kvm: block-qcow2.c:1621: qcow_aio_write_cb: Assertion `(acb->cluster_offset & 511) == 0' failed.
Aborted (core dumped)
  
Actual results:
core dumped

Expected results:
guest work well

Additional info:
kvm storage: block device(iscsi)
Comment 1 FuXiangChun 2011-06-22 06:38:30 EDT
repeat 3 times for above steps, 100% reproduce.
Comment 2 FuXiangChun 2011-06-22 06:40:03 EDT
Created attachment 505964 [details]
backtrace
Comment 3 FuXiangChun 2011-06-23 06:08:03 EDT
since only LV(/dev/vg0/data1) can reproduce this issue. in order to reproduce this bug i did below two testing:  
1. i reinstall guest on LV(/dev/vg0/data1) and run dd command in guest 
2. use other LV to start vm and run dd command in guest

but all can not reproduce this bug, i am not sure how to trigger it.
Comment 4 Kevin Wolf 2011-06-27 05:36:35 EDT
Can you please try qemu-img check on this image? Do you know if there have been I/O errors?
Comment 5 FuXiangChun 2011-06-27 21:22:30 EDT
for block device qemu-img don't support check option. 
# qemu-img check /dev/vg0/data1
qemu-img: This image format does not support checks
Comment 6 Kevin Wolf 2011-06-28 07:24:27 EDT
Try the -f option:

# qemu-img check -f qcow2 /dev/vg0/data1
Comment 7 FuXiangChun 2011-06-28 21:47:35 EDT
hi kevin

   as i suspect guest maybe have problems that lead to core dump, so i reinstalled guest and try to reproduce it on lv data1. but after reinstall guest this bug can not be reproduced. now lv data1 haven't any errors and guest work well. 
# qemu-img check -f qcow2 /dev/vg0/data1
No errors were found on the image.
Comment 8 Kevin Wolf 2011-07-29 03:59:42 EDT
There seems to be a real bug somewhere, but it hasn't been reproduced so far and we don't have any useful information about the broken image. Closing.

Note You need to log in before you can comment on or make changes to this bug.