Bug 715295 - [abrt] grep-2.6.3-2.el6: __libc_message: Process /bin/grep was killed by signal 6 (SIGABRT)
[abrt] grep-2.6.3-2.el6: __libc_message: Process /bin/grep was killed by sign...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grep (Show other bugs)
6.1
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jaroslav Škarvada
Jan Kepler
abrt_hash:afa98f6a8a34a86797c20fda341...
: Patch
Depends On: 713328
Blocks: 836160
  Show dependency treegraph
 
Reported: 2011-06-22 09:39 EDT by Eric Blake
Modified: 2014-01-30 04:21 EST (History)
3 users (show)

See Also:
Fixed In Version: grep-2.6.3-4.el6
Doc Type: Bug Fix
Doc Text:
Cause: For some regular expressions DFA analysis can insert up to double "positions" than there are leaves. Consequence: There are not enough room to insert all the positions which may lead to crash for some REs. Fix: Space allocation for twice as many positions as there are leaves. Result: Enough space, no crash.
Story Points: ---
Clone Of: 713328
Environment:
Last Closed: 2013-06-25 10:18:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Backported fix (2.70 KB, patch)
2012-02-28 07:55 EST, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Eric Blake 2011-06-22 09:39:24 EDT
Cloning, since RHEL 6 is also impacted by this bug.

+++ This bug was initially created as a clone of Bug #713328 +++

abrt version: 1.1.18
architecture: x86_64
Attached file: backtrace, 6479 bytes
cmdline: grep --color=auto -Eq '(^| )*( |$)'
component: grep
Attached file: coredump, 393216 bytes
crash_function: __libc_message
executable: /bin/grep
kernel: 2.6.35.13-92.fc14.x86_64
package: grep-2.8-1.fc14
rating: 4
reason: Process /bin/grep was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1308101349
uid: 14986

How to reproduce
-----
1. grep -Eq '(^| )*( |$)'
2.
3.

--- Additional comment from eblake@redhat.com on 2011-06-14 19:31:00 MDT ---

Created attachment 504787 [details]
File: backtrace

--- Additional comment from jskarvad@redhat.com on 2011-06-20 03:39:47 MDT ---

Upstream commit fixing the issue:
http://git.savannah.gnu.org/cgit/grep.git/commit/?id=0b91d6928e9d098d3746ce9f4bb4160a2e685f5c

--- Additional comment from updates@fedoraproject.org on 2011-06-20 05:54:45 MDT ---

grep-2.8-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/grep-2.8-4.fc15

--- Additional comment from updates@fedoraproject.org on 2011-06-20 05:57:55 MDT ---

grep-2.8-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/grep-2.8-2.fc14

--- Additional comment from updates@fedoraproject.org on 2011-06-21 11:42:57 MDT ---

Package grep-2.8-2.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing grep-2.8-2.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/grep-2.8-2.fc14
then log in and leave karma (feedback).
Comment 2 RHEL Product and Program Management 2011-07-05 20:07:31 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Jaroslav Škarvada 2012-02-28 07:55:25 EST
Created attachment 566302 [details]
Backported fix
Comment 4 Jaroslav Škarvada 2012-02-28 07:57:30 EST
There is also included test in the backported fix.
Comment 11 errata-xmlrpc 2013-06-25 10:18:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0977.html

Note You need to log in before you can comment on or make changes to this bug.