Bug 715315 - Audit remote client gets disk_error event from an auditd server instead of disk_full
Audit remote client gets disk_error event from an auditd server instead of di...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: audit (Show other bugs)
6.1
All Linux
urgent Severity high
: rc
: ---
Assigned To: Steve Grubb
Ondrej Moriš
:
Depends On:
Blocks: RHEL62CCC 730907 846801 846802
  Show dependency treegraph
 
Reported: 2011-06-22 10:27 EDT by Eduard Benes
Modified: 2012-08-08 14:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: audit-2.1.3-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 13:20:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduard Benes 2011-06-22 10:27:01 EDT
Description of problem:
Audit remote client gets disk_error event ack from the server when the disk is full on the server. This way the disk_error_action will be executed instead of configured disk_full_action.

Version-Release number of selected component (if applicable):
audit-2.1-5

How reproducible:
always

Steps to Reproduce:
1. simulate full disk for audit.log to trigger disk_full_action
2. auditctl -m "we want to trigger disk_full_action"
3. 
  
Actual results:
disk_error_action is used instead of disk_full_action

Expected results:
disk_full_action shoudl be triggered as configured

Additional info:
I believe the problem is in write_to_log() function from src/auditd-event.c if statement (saved_errno == ENOSPC && fs_space_left == 1) where it fails on fs_space_left=0 and does not get to do_disk_full_action().
Comment 1 Steve Grubb 2011-06-24 14:48:25 EDT
Patched upstream.
Comment 2 RHEL Product and Program Management 2011-08-04 16:29:59 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 3 Steve Grubb 2011-08-15 16:51:25 EDT
This was addressed in audit-2.1.3-1.el6
Comment 7 errata-xmlrpc 2011-12-06 13:20:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1739.html

Note You need to log in before you can comment on or make changes to this bug.