Bug 715333 - jabberpy is not IPv6 ready
jabberpy is not IPv6 ready
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
541
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zazrivec
Pavel Studeník
:
: 790797 (view as bug list)
Depends On: 740351
Blocks: sat550-post-ga/sat550-test-blockers sat550-ipv6
  Show dependency treegraph
 
Reported: 2011-06-22 10:48 EDT by Milan Zazrivec
Modified: 2012-09-28 09:48 EDT (History)
5 users (show)

See Also:
Fixed In Version: jabberpy-0.5-0.21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-28 09:48:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch addressing the issue (1.69 KB, patch)
2011-06-22 10:48 EDT, Milan Zazrivec
no flags Details | Diff

  None (edit)
Description Milan Zazrivec 2011-06-22 10:48:34 EDT
Created attachment 506027 [details]
Patch addressing the issue

Description of problem:
jabberpy library (and by extension osad / osa-dispatcher) are not IPv6
ready. The library simply assumes all connections to jabber server are
plan IPv4.

Version-Release number of selected component (if applicable):
jabberpy-0.5-0.20

How reproducible:
Always

Steps to Reproduce:
1. Install Satellite 5.4.1 in an IPv6 only environment
2. Make sure jabberd services are listening on IPv6 addresses (but #715299)
3. Check osa-dispatcher startup.
  
Actual results:
osa-dispatcher won't start, following error is present in osa-dispatcher.log:

Traceback (most recent call last):
  File "/usr/share/rhn/osad/jabber_lib.py", line 254, in setup_connection
    c = self._get_jabber_client(js)
  File "/usr/share/rhn/osad/jabber_lib.py", line 311, in _get_jabber_client
    c.connect()
  File "/usr/share/rhn/osad/jabber_lib.py", line 577, in connect
    jabber.Client.connect(self)
  File "/usr/lib/python2.6/site-packages/jabber/xmlstream.py", line 464, in connect
    else: self._sock.connect((self._hostIP, self._port))
  File "<string>", line 1, in connect
gaierror: [Errno -2] Name or service not known

Expected results:
osa-dispatcher starts all right.

Additional info:
Required for a successful IPv6 Satellite deployment.
Comment 1 Milan Zazrivec 2011-10-07 10:00:40 EDT
Problem has also been addressed in EPEL (being used in Spacewalk) packages:

http://koji.fedoraproject.org/koji/buildinfo?buildID=265023
http://koji.fedoraproject.org/koji/buildinfo?buildID=265022
Comment 2 Milan Zazrivec 2012-01-23 08:26:52 EST
thirdparty.git SATELLITE-5.4: 46196d64086409d7d285a5b3e6641c0f21f11a5a
Comment 3 Jan Pazdziora 2012-03-15 11:29:19 EDT
*** Bug 790797 has been marked as a duplicate of this bug. ***
Comment 4 Jan Pazdziora 2012-03-15 11:31:01 EDT
When building the packages, please also add fix for bug 740351.

Note You need to log in before you can comment on or make changes to this bug.