Bug 715461 - KDE's wireless broken on secure AP w/ manual entry
Summary: KDE's wireless broken on secure AP w/ manual entry
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukáš Tinkl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-22 23:54 UTC by Jerry Amundson
Modified: 2015-07-13 17:36 UTC (History)
5 users (show)

Fixed In Version: kde-plasma-networkmanagement-0.9-0.59.20110919git.nm09.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-27 22:59:16 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 240322 None None None Never

Description Jerry Amundson 2011-06-22 23:54:42 UTC
Description of problem:
KDE's wireless broken on secure AP w/ manual entry

Version-Release number of selected component (if applicable):
kde-plasma-networkmanagement-0.9-0.47.20110323.fc15

How reproducible:
always

Steps to Reproduce:
1.login to KDE, and click the (useless) dot for NM access
2.click Manage Connections.. button
3.enter wireless access settings
  
Actual results:
nothing

Expected results:
a wireless network connection

Additional info:
Current test was done from the KDE Live CD.
From .xsession-errors:
kcmshell(21945)/Network Management (ui) WirelessPreferences::WirelessPreferences: Could not find deviceUni or AP UNI in args: (QVariant(QString, "{2b7a0321-3860-4f4c-8d86-f4167f10d43e}") )

Comment 1 Jerry Amundson 2011-06-24 02:52:29 UTC
Just guessing with the upstream bug as there is not much info.

Comment 2 Jerry Amundson 2011-07-07 04:44:42 UTC
Seems to be a slight change between 
1:kde-plasma-networkmanagement-0.9-0.47.20110323.fc15.1.i686
and
1:kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15.i686
now I can manually add the connection, then activate it with "nmcli con up id
Home".
This may be a complete red herring however, in that it may be random bits
backed by inadequate testing. That's more likely, considering there has been no
other feedback here.

Comment 3 Kevin Kofler 2011-07-07 08:02:12 UTC
This difference is because kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15.i686 stores connections in NetworkManager's systemwide storage, kde-plasma-networkmanagement-0.9-0.47.20110323.fc15.1.i686 stored them in its own config files.

Comment 4 Fedora Update System 2011-09-09 23:16:31 UTC
kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-11509

Comment 5 Fedora Update System 2011-09-15 17:47:35 UTC
kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15

Comment 6 Fedora Update System 2011-09-16 02:00:51 UTC
Package kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15
then log in and leave karma (feedback).

Comment 7 collura 2011-09-19 18:16:37 UTC
got bogged down so missed the 
   kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15 
test going through, but i did just run across the
   kde-plasma-networkmanagement-0.9-0.58.20110918git.nm09.fc15
test which i tried and can report that by that time 
it certainly does fix things nicely :')

if i try to name a hidden network in the plasma applet it dutifully pops up the network definition interface so i can enter the connection info.

used the restrict to interface option and used with/without the 'system' checkbox (yay option to saves typing walet password at reboot) and works great.  

thanks.

Comment 8 Fedora Update System 2011-09-27 22:58:54 UTC
kde-plasma-networkmanagement-0.9-0.59.20110919git.nm09.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-09-30 18:51:10 UTC
kde-plasma-networkmanagement-0.9-0.59.20110919git.nm09.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.