Bug 71550 - Installer fails when proceeding further than the Account creation section due to an IO Error
Installer fails when proceeding further than the Account creation section due...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-14 22:30 EDT by Gabriel
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 22:31:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump from the installation (39.43 KB, text/plain)
2002-08-14 22:31 EDT, Gabriel
no flags Details

  None (edit)
Description Gabriel 2002-08-14 22:30:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Well, I cannot proceed any further in the installation process because of an IO 
Error...  How to reproduce it?  Well, I simply install as a dual boot system 
(the first OS installed was Windows 2000) and after setting up the accounts, I 
get that IO Error...  I have attached the dump it has saved on a floppy disk...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Windows 2000
2.Start up Linux's install
3.Install as a workstation
4.Install as a dual boot system
5.Proceed until the Account creation screen
6.Create one account and click 'next'
	

Actual Results:  Got an IO Error which made the Installation failed.

Expected Results:  It should have showed me the next screen of the installation 
process.

Additional info:

Here's the error I saw inside the popup...

Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 130, in __call__
    ret = apply(self.func, a)
  File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 106, in readPackages
    id.comps = method.readComps(id.hdList)
  File "/usr/lib/anaconda/installmethod.py", line 26, in readComps
    return self.readCompsViaMethod(hdlist)
  File "/usr/lib/anaconda/image.py", line 17, in readCompsViaMethod
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/usr/lib/anaconda/comps.py", line 796, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/lib/anaconda/comps.py", line 480, in readCompsFile
    lines = file.readlines()
IOError: [Errno 5] Input/output error
Comment 1 Gabriel 2002-08-14 22:31:05 EDT
Created attachment 70745 [details]
Dump from the installation
Comment 2 Michael Fulbright 2002-08-15 12:18:25 EDT
Your CD is bad.

Note You need to log in before you can comment on or make changes to this bug.