This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 715549 - LibreOffice does not recognise fonts without a suffix
LibreOffice does not recognise fonts without a suffix
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-23 06:17 EDT by Alex Hudson (Fedora Address)
Modified: 2011-08-01 22:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: libreoffice-3.3.3.1-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-01 22:11:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Verbose output of my font list. (368.65 KB, text/plain)
2011-07-19 07:07 EDT, Alex Hudson (Fedora Address)
no flags Details

  None (edit)
Description Alex Hudson (Fedora Address) 2011-06-23 06:17:51 EDT
Description of problem:

I've been messing around trying to get LibreOffice to see some fonts I have, which are not packaged for Fedora, and getting absolutely nowhere. I've tried installing them in ~/.fonts, /usr/local/share/fonts, /usr/share/fonts, and nothing seems to work.

I've run fc-cache, and fc-list sees the font. If I run Inkscape, the font shows up in the dropdown there. So I'm pretty sure the font is correctly installed.

Obviously, without the ability to install the correct font, it's impossible to open some documents correctly because the metrics are incompatible and the document reflows incorrectly.

Version-Release number of selected component (if applicable):

libreoffice-core-3.3.3.1-1.fc15.x86_64
Comment 1 Caolan McNamara 2011-06-23 06:55:46 EDT
Are they outline fonts, attach the output of fc-list -v and mention the name of one of the fonts that isn't being shown in LibreOffice which is being shown in e.g. Inkscape.
Comment 2 Caolan McNamara 2011-06-23 07:07:39 EDT
I dumped PALSCRI.TTF in .fonts, fc-list shows an extra "Palace Script MT", and launched LibreOffice and "Palace Script MT" was available.
Comment 3 Old Uncle 2011-07-15 15:56:50 EDT
Same problem here.

Fedora 15. kernel 2.6.38.8-35.fc15.i686

LibreOffice version: 3.3.3.1-2.fc15

Installed additional fonts with Fontmatrix.

LibreOffice fails to recognize added fonts.

Installed Abiword - same result.

IMO the problem is related to kernel version.
I didn't have problem with previous kernels.
Unfortunately, yesterday, I deleted previous kernels and can not test my guess...
Comment 4 Caolan McNamara 2011-07-17 06:02:37 EDT
so, two reports that newly added fonts don't appear in applications. But they *are* appearing in fc-list, right ? Do they appear or not appear in e.g. gedit ?
Comment 5 Alex Hudson (Fedora Address) 2011-07-19 07:07:30 EDT
Created attachment 513769 [details]
Verbose output of my font list.
Comment 6 Alex Hudson (Fedora Address) 2011-07-19 07:07:43 EDT
Right, I think I understand this now.

I've attached the output of "fc-list -v". The missing fonts are generally of the "ITC Avant Garde" family.

However, when I was looking through the output, I noticed that my font files were missing file extensions. I've no idea why/how, but I was going through Nautilus to install these, so if they came up as ttf files I probably wouldn't have noticed.

I tried renaming one of the fonts - the Book face - to give it the extension, re-ran fc-cache, and lo it now appears in LibreOffice.

So, it seems like for some reason the font is being ignored if LibreOffice doesn't like the file name for some reason? I'm assuming it's an app problem because Inkscape seems to be quite happy with them.
Comment 7 Caolan McNamara 2011-07-19 07:34:04 EDT
aha!, excellent catch. Indeed, it needs to see the suffix to do the right thing.

We should simply fix this for the case where we get the font from fontconfig which tells us what format it is.
Comment 8 Caolan McNamara 2011-07-19 08:44:24 EDT
will try and take the fontconfig format when known, fall back to the old suffix detection otherwise. will be >= 3.3.3.1-3
Comment 9 Fedora Update System 2011-07-20 04:02:14 EDT
libreoffice-3.3.3.1-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libreoffice-3.3.3.1-3.fc15
Comment 10 Fedora Update System 2011-07-22 15:25:20 EDT
Package libreoffice-3.3.3.1-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.3.3.1-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libreoffice-3.3.3.1-3.fc15
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2011-08-01 22:11:12 EDT
libreoffice-3.3.3.1-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.