Bug 715587 - Qt library error
Qt library error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-23 08:50 EDT by Adam Huffman
Modified: 2011-06-23 10:45 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-23 10:20:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2011-06-23 08:50:02 EDT
Description of problem:

I have just installed unetbootin on an F14 system and it fails to start.  This is the error when I try to run it:

unetbootin: symbol lookup error: /usr/lib64/libQtNetwork.so.4: undefined symbol: _ZN16QIODevicePrivate4peekEPcx

Version-Release number of selected component (if applicable):
unetbootin-0-8.494bzr.fc14.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Susi Lehtola 2011-06-23 10:12:24 EDT
Looks like Qt has broken the abi without updating the library soname. Reassigning.

(Rebuilt unetbootin to follow.)
Comment 2 Kevin Kofler 2011-06-23 10:20:13 EDT
Uh, rebuilding unetbootin was the wrong thing to do! Your rebuild is completely unnecessary, please don't push it.

This is an unresolved symbol in one of Qt's own libraries. The reporter must have a bundled copy of Qt from some third-party installer which is older than our system Qt and breaks our system Qt apps.
Comment 3 Kevin Kofler 2011-06-23 10:22:19 EDT
(That QIODevice::Private class is a private class in QtCore which is used by QtNetwork from the same version of Qt. Mixing incompatible versions of QtNetwork and QtCore WILL lead to unresolved symbols. They must be from the same version. Please search for bundled copies of libQtCore.so.4 and other libQt* libraries in some application directory and delete them. Your third-party applications should be working fine with our up-to-date system Qt.)
Comment 4 Adam Huffman 2011-06-23 10:45:16 EDT
(In reply to comment #3)
> (That QIODevice::Private class is a private class in QtCore which is used by
> QtNetwork from the same version of Qt. Mixing incompatible versions of
> QtNetwork and QtCore WILL lead to unresolved symbols. They must be from the
> same version. Please search for bundled copies of libQtCore.so.4 and other
> libQt* libraries in some application directory and delete them. Your
> third-party applications should be working fine with our up-to-date system Qt.)

Yes, that does seem to be what's happening - sorry for the noise.

It helps explain why I was having trouble with the third-party program (I've been trying to make an RPM of it, which is proving difficult).

Note You need to log in before you can comment on or make changes to this bug.