Bug 71564 - mount -t smbfs does not return a non zero value when mounting if smbmnt not found
mount -t smbfs does not return a non zero value when mounting if smbmnt not f...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-15 04:55 EDT by Jobst Schmalenbach
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-14 13:33:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jobst Schmalenbach 2002-08-15 04:55:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4.1) Gecko/20020508
Netscape6/6.2.3

Description of problem:
mount does not return an error when smbmnt (used by mount when doing an smbfs
mount) is not found in PATH but actually retuns that there was NO error.

Version-Release number of selected component (if applicable):
RH7.1

How reproducible:
Always

Steps to Reproduce:
As root and make sure /usr/sbin is NOT in path
1. /bin/mount -t smbfs -o username=SOMEVALIDNAME,password=SOMEVALIDPASS
//NTSERVER/SOMESHARE MOUNTPOINT
2. 

Actual Results:  root> /bin/mount -t smbfs -o
username=SOMEVALIDNAME,password=SOMEVALIDPASS //NTSERVER/SOMESHARE MOUNTPOINT >
/dev/null &2>1 
root> $echo $?
root> 0



Expected Results: some value greater 0 indicating that "smbmnt" was NOT found
and the mount did NOT succeed!

Additional info:

And yes, if you not redirect the output (which cannot be done in a script) and
READ the output on the terminal you know something is wrong .... but not when
run as a script ....
Comment 1 Elliot Lee 2003-01-14 13:33:45 EST
with 2.11y-2 I get an error code back, so I'm assuming this has since been fixed.

Note You need to log in before you can comment on or make changes to this bug.