Bug 715666 - FTBFS gdpc-2.2.5-4.fc15 due to unknown type name
FTBFS gdpc-2.2.5-4.fc15 due to unknown type name
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2011-06-23 10:42 EDT by FTBFS
Modified: 2012-01-19 09:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-11 22:15:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (188.85 KB, text/plain)
2011-06-23 10:42 EDT, FTBFS
no flags Details
build.log (128.21 KB, text/plain)
2011-06-23 10:42 EDT, FTBFS
no flags Details
mock.log (1.18 KB, text/plain)
2011-06-23 10:42 EDT, FTBFS
no flags Details
root.log (332.61 KB, text/plain)
2011-06-23 10:42 EDT, FTBFS
no flags Details
build.log (128.05 KB, text/plain)
2011-06-23 10:42 EDT, FTBFS
no flags Details
mock.log (1.19 KB, text/plain)
2011-06-23 10:43 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2011-06-23 10:42:49 EDT
gdpc-2.2.5-4.fc15.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 10:42:53 EDT
Created attachment 506475 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 10:42:54 EDT
Created attachment 506476 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 10:42:55 EDT
Created attachment 506477 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 10:42:57 EDT
Created attachment 506478 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 10:42:59 EDT
Created attachment 506479 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 10:43:00 EDT
Created attachment 506480 [details]
mock.log


mock.log for x86_64
Comment 7 Susi Lehtola 2011-06-24 05:42:23 EDT
Fails due to

/usr/include/pango-1.0/pango/pango-script.h:132:12: error: unknown type name 'G_CONST_RETURN'

refiling bug against pango.
Comment 8 Fedora Admin XMLRPC Client 2012-01-10 10:43:36 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Matthias Clasen 2012-01-11 22:15:07 EST
build with -UG_DISABLE_DEPRECATED then
anyway, G_CONST_RETURN has been removed from pango meanwhile
Comment 10 Susi Lehtola 2012-01-19 09:49:34 EST
Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.