Bug 71571 - Matrox G400: garbled display on startup
Summary: Matrox G400: garbled display on startup
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 82777
TreeView+ depends on / blocked
 
Reported: 2002-08-15 09:45 UTC by Bernhard Rosenkraenzer
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 16:40:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernhard Rosenkraenzer 2002-08-15 09:45:04 UTC
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
With a Matrox G400, the display is often (though not always) garbled on X 
startup (basically, the display is split in 3 parts horizontally, all of which 
display what should be on the screen). 
 
Pressing Ctrl-Alt-+ and Ctrl-Alt-- gets the display into a sane state - looks 
like some initialization code is wrong. 
 
Happens about 80% of the time at 1600x1200, 16bpp 
 
Version-Release number of selected component (if applicable): 
4.2.0-62 
 
How reproducible: 
About 80% 
 
Steps to Reproduce: 
1. On a box with a Matrox G400 AGP card, startx 
	 
 
Actual Results:  garbled display about 80% of the time 
 
Expected Results:  working display 
 
Additional info: 
 
Details of the card: 
Matrox MGA G400 AGP revision 4, 16 MB SGRAM, PCI ID 102b:0525, Subsystem 
102b:19d8 
Intel 440BX chipset

Comment 1 Mike Chambers 2003-01-30 00:45:28 UTC
Please attach your xfree log and config files so this can be better 
diagnosed.  Should this be closed since Bero isn't following Red Hat now or 
still want to troubleshoot it?

Comment 2 Mike A. Harris 2003-01-30 01:20:59 UTC
I haven't tried to reproduce yet, since it is low priority only reported
by one person, but when I do my next G400 brouhaha, I'll probably test
it, so it's ok to keep open until I've tested it or someone else can.

If I can't reproduce it then, I'll reassign it to bero for laughs.  ;o)

He'd probably get a kick out of that.  ;o)

Comment 3 Mike A. Harris 2004-09-24 16:40:43 UTC
We believe this issue to be resolved in our currently shipping
OS releases.  Please upgrade to Fedora Core 2 or later, and if this
issue turns out to still be reproduceable, please file a bug report
in the X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.





Note You need to log in before you can comment on or make changes to this bug.