This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 715831 - FTBFS python-webhelpers-1.3-1.fc16
FTBFS python-webhelpers-1.3-1.fc16
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-webhelpers (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Kyle VanderBeek
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2011-06-23 11:18 EDT by FTBFS
Modified: 2011-12-06 19:00 EST (History)
2 users (show)

See Also:
Fixed In Version: python-webhelpers-1.3-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 19:00:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (29.41 KB, text/plain)
2011-06-23 11:18 EDT, FTBFS
no flags Details
build.log (30.51 KB, text/plain)
2011-06-23 11:18 EDT, FTBFS
no flags Details
mock.log (1.32 KB, text/plain)
2011-06-23 11:18 EDT, FTBFS
no flags Details
root.log (40.72 KB, text/plain)
2011-06-23 11:18 EDT, FTBFS
no flags Details
build.log (30.68 KB, text/plain)
2011-06-23 11:18 EDT, FTBFS
no flags Details
mock.log (1.31 KB, text/plain)
2011-06-23 11:18 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2011-06-23 11:18:19 EDT
python-webhelpers-1.3-1.fc16.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 11:18:23 EDT
Created attachment 507378 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 11:18:24 EDT
Created attachment 507380 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 11:18:26 EDT
Created attachment 507382 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 11:18:27 EDT
Created attachment 507384 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 11:18:28 EDT
Created attachment 507385 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 11:18:30 EDT
Created attachment 507386 [details]
mock.log


mock.log for x86_64
Comment 7 Dave Malcolm 2011-12-06 18:37:18 EST
Failing test is:
======================================================================
FAIL: test_distance_of_time_in_words (test_date.TestDateHelper)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/WebHelpers-1.3/tests/test_date.py", line 24, in test_distance_of_time_in_words
    self.assertEqual("11 months and 30 days", distance_of_time_in_words(0, 31536000))
AssertionError: '11 months and 30 days' != '11 months and 29 days'
----------------------------------------------------------------------
Ran 252 tests in 1.015s
FAILED (SKIP=5, failures=1)

Looks like a leap-year issue.

Also seen by Debian as:
  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=629699

It's being tracked upstream as:
 
https://bitbucket.org/bbangert/webhelpers/issue/61/test_distance_of_time_in_words-fails
Comment 8 Dave Malcolm 2011-12-06 19:00:16 EST
I've patched out the fragile part of the test for now, as:
http://pkgs.fedoraproject.org/gitweb/?p=python-webhelpers.git;a=commitdiff;h=3949b1c8cbd8baf038c94a815aa8cdbc35dfd4f6

and successfully rebuilt as python-webhelpers-1.3-2.fc17 into rawhide.

Note You need to log in before you can comment on or make changes to this bug.