Bug 715882 - FTBFS flterm-1.0-1.rc3.fc15
FTBFS flterm-1.0-1.rc3.fc15
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: flterm (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Shakthi Kannan
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2011-06-23 11:29 EDT by FTBFS
Modified: 2013-02-21 08:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 08:19:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (30.06 KB, text/plain)
2011-06-23 11:29 EDT, FTBFS
no flags Details
build.log (5.17 KB, text/plain)
2011-06-23 11:29 EDT, FTBFS
no flags Details
mock.log (1.20 KB, text/plain)
2011-06-23 11:29 EDT, FTBFS
no flags Details
root.log (38.11 KB, text/plain)
2011-06-23 11:29 EDT, FTBFS
no flags Details
build.log (5.04 KB, text/plain)
2011-06-23 11:29 EDT, FTBFS
no flags Details
mock.log (1.21 KB, text/plain)
2011-06-23 11:29 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2011-06-23 11:29:42 EDT
flterm-1.0-1.rc3.fc15.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 11:29:46 EDT
Created attachment 507661 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 11:29:47 EDT
Created attachment 507662 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 11:29:48 EDT
Created attachment 507663 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 11:29:50 EDT
Created attachment 507664 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 11:29:51 EDT
Created attachment 507665 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 11:29:53 EDT
Created attachment 507666 [details]
mock.log


mock.log for x86_64
Comment 7 Shakthi Kannan 2011-12-23 00:18:20 EST
I have updated flterm to 1.0-1.rc4. It builds fine for F15, F17 and EL6. But, it fails on F16 because of the clang version in it.

I have asked Michel (maintainer of llvm) to look into the build failure.
Comment 8 Shakthi Kannan 2012-05-03 02:46:57 EDT
clang is used to build the flterm executable. On F17, the build is blocked because of:

*** ERROR: No build ID note found in /builddir/build/BUILDROOT/flterm-1.0.1-1.fc17.x86_64/usr/bin/flterm
Comment 9 Mat Booth 2013-02-21 08:19:04 EST
This package appears to be building successfully on all current branches (F17 and newer):

http://koji.fedoraproject.org/koji/packageinfo?packageID=11174

Note You need to log in before you can comment on or make changes to this bug.