Bug 7159 - Sound settings are not loaded if sound is not modular
Sound settings are not loaded if sound is not modular
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-19 16:54 EST by Olivier Crête
Modified: 2014-03-16 22:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-30 16:14:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Crête 1999-11-19 16:54:08 EST
The aumix loading in rc.sysinit is inside a "if" on sound modules (checks
if sound module is in conf.modules, it should be separate and use
/proc/devices like the halt scripts... You know, non modular sound still
exists...

Because right now it does not works with my kernel with non-modular sound
(well I just pulled the aumix part out of the "if" so it would work)

Where is rhsound gone?
Comment 1 Bill Nottingham 1999-11-22 11:12:59 EST
rhsound went away.

This will be fixed in initscripts-4.66-1; the mixer loading
will be done automatically if sound is registered in /proc/devices.
Comment 2 Olivier Crête 1999-11-24 14:42:59 EST
In the new initscript 4.67-1, there is an error in the test for the grep, part
the syntax is totally incorrect, you cannot have a grep directly inside a []
(which stands for the test command (man test and man bash))
The grep and the test have to be separated and combined with "&&" like that:
this is what should be in the next version:

if (grep -q "\(sparcaudio\|sound\)" /proc/devices 2>/dev/null) && [ -f
/etc/.aumixrc -a -x /bin/aumix-minimal ]; then
Comment 3 Bill Nottingham 1999-11-29 11:32:59 EST
fixed in initscripts-4.69-1, in raw hide now.

Note You need to log in before you can comment on or make changes to this bug.