Bug 715949 - FTBFS rubygem-shoulda-2.11.3-1.fc15
FTBFS rubygem-shoulda-2.11.3-1.fc15
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-shoulda (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2011-06-23 11:43 EDT by FTBFS
Modified: 2012-01-24 02:54 EST (History)
2 users (show)

See Also:
Fixed In Version: rubygem-shoulda-2.11.3-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-24 02:54:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (16.13 KB, text/plain)
2011-06-23 11:43 EDT, FTBFS
no flags Details
build.log (1.28 KB, text/plain)
2011-06-23 11:43 EDT, FTBFS
no flags Details
mock.log (1.30 KB, text/plain)
2011-06-23 11:43 EDT, FTBFS
no flags Details
root.log (19.73 KB, text/plain)
2011-06-23 11:43 EDT, FTBFS
no flags Details
build.log (1.30 KB, text/plain)
2011-06-23 11:43 EDT, FTBFS
no flags Details
mock.log (1.23 KB, text/plain)
2011-06-23 11:43 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2011-06-23 11:43:42 EDT
rubygem-shoulda-2.11.3-1.fc15.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 11:43:47 EDT
Created attachment 508022 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 11:43:50 EDT
Created attachment 508023 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 11:43:51 EDT
Created attachment 508024 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 11:43:53 EDT
Created attachment 508025 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 11:43:54 EDT
Created attachment 508026 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 11:43:56 EDT
Created attachment 508027 [details]
mock.log


mock.log for x86_64
Comment 7 Michael Stahnke 2012-01-08 21:44:04 EST
I have done the minimal work to ensure this passes. 

http://koji.fedoraproject.org/koji/taskinfo?taskID=3631958


    The fixes I have provided are completely minimal and just what is needed
    to fix FTBFS.  This package probably needs updates and I'd love to have
    %check enabled.  But since other rubygem packages depend upon this
    package, I wanted to ensure it was not pulled from Fedora.
    
    This commit comments out items used in %%check and BR(check).



I just wanted to ensure the package didn't get pulled from Fedora.
Comment 8 Fedora Update System 2012-01-08 21:54:36 EST
rubygem-shoulda-2.11.3-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rubygem-shoulda-2.11.3-3.fc16
Comment 9 Fedora Update System 2012-01-11 01:11:32 EST
Package rubygem-shoulda-2.11.3-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-shoulda-2.11.3-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0338/rubygem-shoulda-2.11.3-3.fc16
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-01-24 02:54:08 EST
rubygem-shoulda-2.11.3-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.