Bug 71603 - Anaconda unable to unmount second CD of set
Summary: Anaconda unable to unmount second CD of set
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-15 16:51 UTC by Brian M. Sutin
Modified: 2007-04-18 16:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-19 23:42:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full text of anacdump.txt (75.29 KB, text/plain)
2002-08-15 16:52 UTC, Brian M. Sutin
no flags Details

Description Brian M. Sutin 2002-08-15 16:51:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-34smp i686)

Description of problem:
Anaconda is unable to unmount the second CD of the set and crashes.
The CD's are straight from Redhat 7.3.  I ran a mediacheck, and they
passed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  choose all the packages, so the second cd is required.
2.
3.
	

Actual Results:  
Here is the anadump.txt file:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/anaconda/gui.py", line 529, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 135, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 611, in doInstall
    problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE, cb.cb, 0)
  File "/usr/lib/anaconda/packages.py", line 244, in cb
    fn = self.method.getFilename(h, self.pkgTimer)
  File "/usr/lib/anaconda/image.py", line 86, in getFilename
    isys.umount("/mnt/source")
  File "/usr/lib/anaconda/isys.py", line 171, in umount
    rc = _isys.umount(what)
SystemError: (16, 'Device or resource busy')

Local variables in innermost frame:
what: /mnt/source
removeDir: 1

......CUT......

Installing xsnow-1.42-3.
Installing plugger-4.0-6.
Installing autoconvert-0.3.7-6.
Installing autoconvert-xchat-0.3.7-6.
Installing bg5ps-1.3.0-7.
Installing cWnn-common-1.11-20.
Installing cWnn-1.11-20.
Installing libtabe-0.2.4a-10.
Installing miniChinput-0.0.3-18.

....and that's where the anadump.txt file ends....


Additional info:

I found a previous bug report of this exact bug.  The handler closed
the bug with a note that the media must be bad, but mine checks out
fine.

Comment 1 Brian M. Sutin 2002-08-15 16:52:55 UTC
Created attachment 70884 [details]
full text of anacdump.txt

Comment 2 Michael Fulbright 2002-08-19 16:40:11 UTC
The CD test is not 100% perfect at catching problems that can occur during an
install.  I would recommend you try installing from ISOs on your HD instead of
using CDs to see if that works better.

Comment 3 Brian M. Sutin 2002-08-19 23:42:18 UTC
Hello!

I suspect that the CD's are fine, because I found that I could install the
minimal installation and then keep trying to upgrade until all the packages
were installed.  Thus I conclude that no specific rpm on the CD is at fault.

You suggestion is impractical anyway because Redhat almost completely fills
the disk.

Regards,

Brian

Comment 4 Michael Fulbright 2002-08-22 20:07:24 UTC
There are numerous examples of this scenario.

If you purchased the CDs and are having problems you can speak to customer service.



Note You need to log in before you can comment on or make changes to this bug.