Bug 716143 - FTBFS agave-0.4.7-1.fc14
FTBFS agave-0.4.7-1.fc14
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: agave (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
: 631411 (view as bug list)
Depends On:
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2011-06-23 12:23 EDT by FTBFS
Modified: 2012-02-06 14:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-06 14:35:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (949.01 KB, text/plain)
2011-06-23 12:23 EDT, FTBFS
no flags Details
build.log (31.32 KB, text/plain)
2011-06-23 12:23 EDT, FTBFS
no flags Details
mock.log (1.32 KB, text/plain)
2011-06-23 12:23 EDT, FTBFS
no flags Details
root.log (1.45 MB, text/plain)
2011-06-23 12:23 EDT, FTBFS
no flags Details
build.log (31.15 KB, text/plain)
2011-06-23 12:23 EDT, FTBFS
no flags Details
mock.log (1.20 KB, text/plain)
2011-06-23 12:23 EDT, FTBFS
no flags Details
Fix (1.65 KB, patch)
2011-07-19 16:37 EDT, Petr Machata
no flags Details | Diff
Fix (1.57 KB, patch)
2011-07-19 16:40 EDT, Petr Machata
no flags Details | Diff

  None (edit)
Description FTBFS 2011-06-23 12:23:45 EDT
agave-0.4.7-1.fc14.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 12:23:48 EDT
Created attachment 509138 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 12:23:50 EDT
Created attachment 509139 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 12:23:51 EDT
Created attachment 509140 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 12:23:54 EDT
Created attachment 509141 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 12:23:56 EDT
Created attachment 509142 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 12:23:58 EDT
Created attachment 509143 [details]
mock.log


mock.log for x86_64
Comment 7 Petr Machata 2011-07-19 16:37:05 EDT
Created attachment 513880 [details]
Fix

I believe that what the code intends to do is call the default ctor.  Unfortunately, the construct "SchemeBox::SchemeBox()" creates a new anonymous object, and immediately destroys it.  It's not possible to delegate constructors like that in c++.  Up until now, that code was tolerated by gcc, now it's diagnosed.  The patch moves the common code into separate function, inlines the initializer and then calls that function from both ctors.
Comment 8 Petr Machata 2011-07-19 16:40:22 EDT
Created attachment 513881 [details]
Fix

Oh wait, that initializer shouldn't be necessary.
Comment 9 Vivek Shah 2011-09-18 08:05:20 EDT
*** Bug 631411 has been marked as a duplicate of this bug. ***
Comment 10 Gwyn Ciesla 2011-09-27 13:48:45 EDT
This works, but gnome-vfsmm26 is retired.  Unless that's going to be resurrected, this should be closed.

Note You need to log in before you can comment on or make changes to this bug.