Bug 716144 - FTBFS curry-0.9.11-7.fc12
FTBFS curry-0.9.11-7.fc12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: curry (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2011-06-23 12:24 EDT by FTBFS
Modified: 2012-03-08 23:52 EST (History)
1 user (show)

See Also:
Fixed In Version: curry-0.9.11-11.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-08 23:52:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (33.30 KB, text/plain)
2011-06-23 12:24 EDT, FTBFS
no flags Details
build.log (4.51 KB, text/plain)
2011-06-23 12:24 EDT, FTBFS
no flags Details
mock.log (1.32 KB, text/plain)
2011-06-23 12:24 EDT, FTBFS
no flags Details
root.log (56.46 KB, text/plain)
2011-06-23 12:24 EDT, FTBFS
no flags Details
build.log (4.47 KB, text/plain)
2011-06-23 12:24 EDT, FTBFS
no flags Details
mock.log (1.34 KB, text/plain)
2011-06-23 12:24 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2011-06-23 12:24:00 EDT
curry-0.9.11-7.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 12:24:03 EDT
Created attachment 509144 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 12:24:04 EDT
Created attachment 509145 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 12:24:06 EDT
Created attachment 509146 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 12:24:07 EDT
Created attachment 509147 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 12:24:08 EDT
Created attachment 509148 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 12:24:09 EDT
Created attachment 509149 [details]
mock.log


mock.log for x86_64
Comment 7 Jens Petersen 2012-03-04 20:48:31 EST
Just guessing from the build.log that it is probably missing 
"-package haskell98" which is now needed to get haskell98.
Comment 8 Jens Petersen 2012-03-05 02:57:24 EST
Actually the originally failure no longer applies since ghc
no pulls in haskell98 again.

I worked around a further build problem: iso88591 encoded .curry files breaking cycc in the build, but I am not sure if that is the right fix, or even if people still need curry. :)

Anyway this build fixes the dependency change for gmp version in f17.
Comment 9 Fedora Update System 2012-03-05 03:03:33 EST
curry-0.9.11-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/curry-0.9.11-11.fc17
Comment 10 Fedora Update System 2012-03-05 15:55:58 EST
Package curry-0.9.11-11.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing curry-0.9.11-11.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2864/curry-0.9.11-11.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-03-08 23:52:04 EST
curry-0.9.11-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.