Bug 716183 - FTBFS python-daemon-1.5.2-3.fc15
FTBFS python-daemon-1.5.2-3.fc15
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-daemon (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: kushaldas@gmail.com
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Reopened, Triaged
Depends On:
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2011-06-23 12:31 EDT by FTBFS
Modified: 2013-02-21 09:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 09:11:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (27.17 KB, text/plain)
2011-06-23 12:31 EDT, FTBFS
no flags Details
build.log (41.90 KB, text/plain)
2011-06-23 12:31 EDT, FTBFS
no flags Details
mock.log (1.36 KB, text/plain)
2011-06-23 12:31 EDT, FTBFS
no flags Details
root.log (36.84 KB, text/plain)
2011-06-23 12:31 EDT, FTBFS
no flags Details
build.log (41.98 KB, text/plain)
2011-06-23 12:31 EDT, FTBFS
no flags Details
mock.log (1.24 KB, text/plain)
2011-06-23 12:31 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2011-06-23 12:31:29 EDT
python-daemon-1.5.2-3.fc15.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 12:31:32 EDT
Created attachment 509367 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 12:31:33 EDT
Created attachment 509368 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 12:31:35 EDT
Created attachment 509369 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 12:31:36 EDT
Created attachment 509370 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 12:31:37 EDT
Created attachment 509371 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 12:31:39 EDT
Created attachment 509372 [details]
mock.log


mock.log for x86_64
Comment 7 Thomas Spura 2011-06-24 04:18:41 EDT
Tests in minimock are failing:
ERROR: DaemonContext component should have specified stderr file.
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/python-daemon-1.5.2/test/test_runner.py", line 207, in setUp
    set_runner_scenario(self, 'simple')
  File "/builddir/build/BUILD/python-daemon-1.5.2/test/test_runner.py", line 97, in set_runner_scenario
    testcase, testcase.scenario['pidlockfile_scenario_name'])
  File "/builddir/build/BUILD/python-daemon-1.5.2/test/test_runner.py", line 108, in set_pidlockfile_scenario
    testcase.lockfile_class_name)
  File "/builddir/build/BUILD/python-daemon-1.5.2/test/test_pidlockfile.py", line 296, in setup_lockfile_method_mocks
    tracker=testcase.mock_tracker)
  File "/usr/lib/python2.7/site-packages/minimock.py", line 200, in mock
    original = tmp.__dict__[attrs[-1]]
KeyError: 'read_pid'
======================================================================
ERROR: DaemonContext component should have specified stdin file.
Comment 8 kushaldas@gmail.com 2011-07-14 02:44:56 EDT
Updated rawhide with 1.6 version
Comment 9 Fedora Update System 2011-07-14 02:51:56 EDT
python-daemon-1.6-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/python-daemon-1.6-1.fc15
Comment 10 Sandro Bonazzola 2011-07-15 02:34:08 EDT
(In reply to comment #9)
> python-daemon-1.6-1.fc15 has been submitted as an update for Fedora 15.
> https://admin.fedoraproject.org/updates/python-daemon-1.6-1.fc15

This is broken in Fedora 15:
$ python
Python 2.7.1 (r271:86832, Apr 12 2011, 16:16:18) 
[GCC 4.6.0 20110331 (Red Hat 4.6.0-2)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from daemon import pidfile
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/daemon/pidfile.py", line 18, in <module>
    from lockfile.pidlockfile import PIDLockFile
ImportError: No module named pidlockfile

If you plan to bump python-lockfile to 0.9 in order to fix this, please review bug #612403.
Comment 11 kushaldas@gmail.com 2011-07-15 03:01:15 EDT
I did a local build of python-lockfile to 0.9.1 . The import test as mention above worked well. Can we get the python-lockfile updated now ?
Comment 12 Thomas Spura 2011-07-15 08:54:13 EDT
When the updated lockfile still works with minimock, then it's ok.

lockfile 0.9 had a huge abi break, and minimock was unusable.
When that has changed in 0.9.1 (and an update of minimock) it's ok.
(but can't check that right now
Comment 13 Thomas Spura 2011-07-17 07:11:23 EDT
All tests of python-daemon 1.6 pass again with lockfile-0.9.1, so I think, it's ok to update it.

Can the testsuite of python-daemon be run again, when building, please?
Comment 14 Vladimir Mosgalin 2011-11-02 07:04:53 EDT
python-daemon-1.6-1.fc15.noarch.rpm from FC15 testing repo breaks Orbited (orbited-0.7.10-7.fc15.noarch) due to bug described above (error when importing pidlockfile), which crashes when started as system service then.

Rolling back to python-daemon-1.5.2-3.fc15.noarch.rpm and python-lockfile-0.8-2.fc15.noarch.rpm fixes it.
Comment 15 Mat Booth 2013-02-21 09:11:20 EST
This package appears to be building successfully for all current branches:

http://koji.fedoraproject.org/koji/packageinfo?packageID=8695

Note You need to log in before you can comment on or make changes to this bug.