Bug 716193 - FTBFS notecase-1.6.1-6.fc12: ImplicitDSOLinking
FTBFS notecase-1.6.1-6.fc12: ImplicitDSOLinking
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: notecase (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Martin-Gomez Pablo
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F15FTBFS
  Show dependency treegraph
 
Reported: 2011-06-23 12:33 EDT by FTBFS
Modified: 2012-07-06 19:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-06 19:07:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (468.71 KB, text/plain)
2011-06-23 12:33 EDT, FTBFS
no flags Details
build.log (109.24 KB, text/plain)
2011-06-23 12:33 EDT, FTBFS
no flags Details
mock.log (1.28 KB, text/plain)
2011-06-23 12:33 EDT, FTBFS
no flags Details
root.log (727.84 KB, text/plain)
2011-06-23 12:33 EDT, FTBFS
no flags Details
build.log (108.75 KB, text/plain)
2011-06-23 12:33 EDT, FTBFS
no flags Details
mock.log (1.29 KB, text/plain)
2011-06-23 12:33 EDT, FTBFS
no flags Details
patch to fix #716193 (2.33 KB, patch)
2011-07-11 17:36 EDT, Richard Fearn
no flags Details | Diff

  None (edit)
Description FTBFS 2011-06-23 12:33:25 EDT
notecase-1.6.1-6.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 12:33:28 EDT
Created attachment 509418 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 12:33:29 EDT
Created attachment 509419 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 12:33:30 EDT
Created attachment 509420 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 12:33:32 EDT
Created attachment 509421 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 12:33:33 EDT
Created attachment 509422 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 12:33:35 EDT
Created attachment 509423 [details]
mock.log


mock.log for x86_64
Comment 7 Richard Fearn 2011-07-11 17:36:49 EDT
Created attachment 512292 [details]
patch to fix #716193

This is the same problem as #631448 and #565174.

The patch in #565174 (that adds -lX11 to LDFLAGS) is fine - but causes -lX11 to appear in the ld command line twice.

Adding it directly to the command line (as in this patch) is marginally better - but -lX11 needs to come *after* the list of object files.

Note You need to log in before you can comment on or make changes to this bug.