Bug 716218 - FTBFS icewm-1.2.37-7.fc13: ImplicitDSOLinking
FTBFS icewm-1.2.37-7.fc13: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: icewm (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Gilboa Davara
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
: 661097 (view as bug list)
Depends On:
Blocks: F15FTBFS
  Show dependency treegraph
 
Reported: 2011-06-23 12:38 EDT by FTBFS
Modified: 2011-12-10 16:30 EST (History)
3 users (show)

See Also:
Fixed In Version: icewm-1.3.7-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-04 19:23:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (739.00 KB, text/plain)
2011-06-23 12:38 EDT, FTBFS
no flags Details
build.log (155.50 KB, text/plain)
2011-06-23 12:38 EDT, FTBFS
no flags Details
mock.log (1.19 KB, text/plain)
2011-06-23 12:38 EDT, FTBFS
no flags Details
root.log (1.18 MB, text/plain)
2011-06-23 12:38 EDT, FTBFS
no flags Details
build.log (217.28 KB, text/plain)
2011-06-23 12:38 EDT, FTBFS
no flags Details
mock.log (1.33 KB, text/plain)
2011-06-23 12:38 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2011-06-23 12:38:02 EDT
icewm-1.2.37-7.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 12:38:05 EDT
Created attachment 509560 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 12:38:07 EDT
Created attachment 509561 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 12:38:08 EDT
Created attachment 509562 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 12:38:10 EDT
Created attachment 509563 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 12:38:12 EDT
Created attachment 509564 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 12:38:13 EDT
Created attachment 509565 [details]
mock.log


mock.log for x86_64
Comment 7 Henrik Nordström 2011-09-11 17:43:16 EDT
*** Bug 661097 has been marked as a duplicate of this bug. ***
Comment 8 Henrik Nordström 2011-09-11 17:45:13 EDT
Any progress of getting this FTBFS failure fixed?

The current package in F15 fails to build and the armv7 bootstrap needs a working F15 source package to build from.
Comment 9 Gilboa Davara 2011-09-19 04:09:42 EDT
Currently nope; I'm considering switching the F16/devel/EL6 branch to the better supported icewm 1.3.x branch.

- Gilboa
Comment 10 Fedora Update System 2011-11-23 15:15:53 EST
icewm-1.3.7-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/icewm-1.3.7-1.fc16
Comment 11 Fedora Update System 2011-11-23 15:16:24 EST
icewm-1.3.7-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/icewm-1.3.7-1.el5
Comment 12 Fedora Update System 2011-11-23 15:17:12 EST
icewm-1.3.7-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/icewm-1.3.7-1.el6
Comment 13 Fedora Update System 2011-11-23 15:17:43 EST
icewm-1.3.7-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/icewm-1.3.7-1.fc15
Comment 14 Henrik Nordström 2011-11-24 07:30:15 EST
Thanks!

unfortunately can't build it on right now arm due to transition to a new koji setup. But it will get there.
Comment 15 Fedora Update System 2011-11-24 20:55:06 EST
Package icewm-1.3.7-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing icewm-1.3.7-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16350/icewm-1.3.7-1.fc15
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2011-12-04 19:23:47 EST
icewm-1.3.7-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2011-12-04 19:28:12 EST
icewm-1.3.7-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2011-12-10 16:24:23 EST
icewm-1.3.7-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2011-12-10 16:30:09 EST
icewm-1.3.7-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.