Bug 716228 - anaconda crashes if FAT32 USB stick plugged in
anaconda crashes if FAT32 USB stick plugged in
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-23 13:31 EDT by Bob Nolty
Modified: 2011-07-23 02:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 14:56:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Nolty 2011-06-23 13:31:58 EDT
Description of problem:

Booted F15 live CD.  Clicked Install to Disk.  Anaconda crashed while examining disks.  Removed FAT32-formatted USB stick, reran, and Anaconda succeeded.


Version-Release number of selected component (if applicable):

anaconda-15.31-1.fc15 -- both i686 and x86_64

How reproducible:

I tried anaconda a half dozen times, with both i686 and x86_64 live CDs, and failed every time the USB stick was present.


Steps to Reproduce:
1.Insert a FAT32-formatted USB flash drive into a USB slot
2.Boot off a F15 live CD
3.Click "Install to Hard Drive" icon in dock
4.Click "next" twice
  
Actual results:
After displaying "Examining storage devices" informational pop-up, Anaconda disappears without a trace.

Running anaconda directly from command line, I got:



# anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
10:27:07 Starting graphical installation.
Loading /lib/kbd/keymaps/i386/qwerty/us.map.gz
Backtrace has 20 calls on stack:
  20: /lib64/libparted.so.0(ped_assert+0x2e) [0x7f849d431abe]
  19: /lib64/libparted.so.0(+0x3c036) [0x7f849d45b036]
  18: /lib64/libparted.so.0(+0x3c41e) [0x7f849d45b41e]
  17: /lib64/libparted.so.0(+0x3cae6) [0x7f849d45bae6]
  16: /lib64/libparted.so.0(ped_disk_add_partition+0x1a3) [0x7f849d437873]
  15: /lib64/libparted.so.0(+0x3e279) [0x7f849d45d279]
  14: /lib64/libparted.so.0(+0x3ef95) [0x7f849d45df95]
  13: /lib64/libparted.so.0(ped_disk_new+0x58) [0x7f849d437cd8]
  12: /usr/lib64/python2.7/site-packages/_pedmodule.so(_ped_Disk_init+0x66) [0x7f849d6b0be6]
  11: /usr/lib64/libpython2.7.so.1.0(+0x9d8d8) [0x7f84b04198d8]
  10: /usr/lib64/libpython2.7.so.1.0(PyObject_Call+0x53) [0x7f84b03c4fe3]
  9: /usr/lib64/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x3b73) [0x7f84b045a0a3]
  8: /usr/lib64/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x855) [0x7f84b045d125]
  7: /usr/lib64/libpython2.7.so.1.0(+0x6daa3) [0x7f84b03e9aa3]
  6: /usr/lib64/libpython2.7.so.1.0(PyObject_Call+0x53) [0x7f84b03c4fe3]
  5: /usr/lib64/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x1340) [0x7f84b0457870]
  4: /usr/lib64/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x855) [0x7f84b045d125]
  3: /usr/lib64/libpython2.7.so.1.0(+0x6daa3) [0x7f84b03e9aa3]
  2: /usr/lib64/libpython2.7.so.1.0(PyObject_Call+0x53) [0x7f84b03c4fe3]
  1: /usr/lib64/libpython2.7.so.1.0(+0x57b6f) [0x7f84b03d3b6f]
Aborted (core dumped)



# lsusb
...
Bus 001 Device 006: ID 0930:6545 Toshiba Corp. Kingston DataTraveler 102 flash drive
# fdisk /dev/sdb

Command (m for help): p

Disk /dev/sdb: 4007 MB, 4007657472 bytes
86 heads, 22 sectors/track, 4137 cylinders, total 7827456 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        8064     7827455     3909696    c  W95 FAT32 (LBA)


Expected results:

Anaconda succeeds in installing Fedora to hard drive


Additional info:
Comment 1 Brian Lane 2011-06-27 14:56:01 EDT
This is due to parted being over-zealous when it tries to detect the CHS of the USB stick. This has been fixed in parted-2.4 but we can't update the install media so:

You can work around this problem by removing the partitioning from the usb stick with dd if=/dev/zero of=/dev/blah bs=1M count=1 (this will delete all data from the stick). And then re-partitioning it with parted.
Comment 2 Mike Rubel 2011-07-23 02:33:26 EDT
I realize this is closed, but wanted to ask whether there are any other workarounds.  I can't use the workaround above, because I have to use the USB stick to install from.  (The network card in this Asus 1015PX-PU17 netbook is not recognized by gPXE, so network booting is out, and there are no optical drives or other interfaces.)

I tried formatting the partition as ext2, but the failure mode was the same as for FAT32.

Is my only option to wait for Fedora 16?

Note You need to log in before you can comment on or make changes to this bug.