Bug 71632 - screen resolution problem
screen resolution problem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-15 19:04 EDT by Don Hardaway
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 05:39:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is the X config file (3.08 KB, text/plain)
2002-08-26 18:08 EDT, Don Hardaway
no flags Details
Here is the Log file for X (35.37 KB, text/plain)
2002-08-26 18:09 EDT, Don Hardaway
no flags Details

  None (edit)
Description Don Hardaway 2002-08-15 19:04:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
On my Dell C800 laptop with a screen size of 1600x1200 I can not get a
resolution of 1024x768 and therefore can not read the screen very well. It has a
ATI Mobility M4 32MB graphics card. It basically ignores any lower resolution.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.choose a screen of 1600x1200 laptop under dell.
2.choose ati rage mobility m4 or ati rage 128 mobility
3.choose a resolution of 1024x768.
	

Actual Results:  I get font sizes that appear to be 1600x1200 resolution.

Expected Results:  I should get larger font sizes that scale to the 1024x768
screen size as it does in windows 2000.

Additional info:

I don't know if it is a bug in the X server 4.2.0 or in the r128 driver.
Comment 1 Alexander Larsson 2002-08-16 03:47:38 EDT
mharris, i think this is yours.
Comment 2 Don Hardaway 2002-08-17 12:16:28 EDT
Could my problem be the same as reported in 70073. That the compiler used to
compile XFree86 in limbo2 had a flaw?
Comment 3 Mike A. Harris 2002-08-22 11:01:39 EDT
Anything is possible.  We don't know conclusively that there was a
compiler bug.  That was speculation.  Without complete full analysis
of the problem it is all speculation.

Does it work for you now using the Null beta, with the latest
rawhide XFree86?
Comment 4 Don Hardaway 2002-08-22 16:23:00 EDT
I have not tried the rawhide XFree86.  I also get the white screen when
launching a console as the other bug reported that uses a dell c800 laptop. I
will try to get the rawhide XFree86 if you like or will a new beta be coming out
soon?
Comment 5 Don Hardaway 2002-08-22 17:11:30 EDT
I am sorry. I misunderstood your comment about the null beta.  I am now
downloading  it to try out.
Comment 6 Don Hardaway 2002-08-23 13:48:50 EDT
OK. I loaded null.  Still the screen resolution will not go to 1024x768.  In
fact, I beleive the font size in mozilla is worst than it was with limbo beta2.
It appears to be 1600x1200 resolution instead of 1280x1024.  1280x1024 is the
lowest resolution i can get to work.
Comment 7 Don Hardaway 2002-08-26 11:14:01 EDT
I just learned something else. When I use the Display tool under System Settings
to change monitors from a Dell laptop with a 1280x1024 to a 1600x1200 the fonts
in my browser look better. I noticed that the only thing that changed was the
vertical refresh rate from 75 to 85 on the upper end. Is it possible that if I
enter a modeline of 1024x768 and get the real refresh rates V and H from Dell
form my screen and enter those that I will be able to get the 1024x768
resolution that I want? Please advise on what i should do next.
Comment 8 Mike A. Harris 2002-08-26 15:27:56 EDT
Potentially, however I can't really advise you in either way.  The only
way to know is to try it.  I don't have such hardware to make a remotely
accurate guess.

Also, I must point out that your request is more of a technical support
type of request than a bug report.  Bugzilla is strictly for bug reporting
and tracking.  You should use Red Hat and/or XFree86 mailing lists for
technical support type of questions.

For now, what I suggest is that you attach your XFree86 config file,
and X server log file to the bug report as individual file attachments
using the link below.  I'll examine their output and see if there
is anything obvious there.
Comment 9 Don Hardaway 2002-08-26 18:08:50 EDT
Created attachment 73224 [details]
Here is the X config file
Comment 10 Don Hardaway 2002-08-26 18:10:00 EDT
Created attachment 73225 [details]
Here is the Log file for X
Comment 11 Don Hardaway 2002-08-26 18:19:37 EDT
I have attached the log and config files for X. I do have to disagree with your
comment about needing technical support instead of a bug problem.  I earlier
comments about trying some different modelines and getting refresh information
from Dell was in the spirit of trying to help locate what the configuration
program that redhat uses is failing to do.  After all, my Windows 2000
installation does not have this problem on the same machine.  Unless my
understanding is incorrect, the next Redhat release is aimed more at the
desktop, I think this kind of problem is critical since many corporations have
Dell laptops in addition to the consumer market.  I consider this a bug since
changing resolutions as show in the options of the program that works with the
Display under System Settings does not work. I notice bug report 72153 is also
having problems. I have as well experienced the white screen issue but not often.
Comment 12 Mike A. Harris 2002-08-27 05:45:30 EDT
Linux is not Windows 2000.  EVERYTHING works in Windows, because the
hardware vendors write 100% for their video hardware in Windows, and
have it tested and certified before they get the Microsoft stamp
of approval.  That is just the way it is.

In Linux, we have _partial_ driver support for most hardware.  Barely
any video drivers cover 100% of the functionality of the particular
video card.  Source is contributed by _some_ vendors, but not all.

Any version of Windows working on ANY machine is in absolutley no
way whatsoever indicative of anything at all working at ALL in Linux.

I didn't say this wasn't a bug.  I said that your last comment was
more of a tech support question.  I do NOT answer tech support
questions in bug reports because I do not have the time to do so.
If someone can ask tech support questions on a mailing list or
somesuch and get an answer, me answering it here is taking my time
away from fixing bugs.  Bugs such as this one.  Then less bugs
get fixed, and more sit here open.

I do not have any laptop hardware at all, let alone a specific
laptop.  I therefore can not reproduce this or really do much about
it at all without a lot more information from someone with the
hardware.

This is frustrating.  Frustrating for you, because you have the
problem, and frustrating for me, because I likely can't do much
about it.  I still get to listen to users compare us to things
like WIndows though, and that doesn't help me fix bugs.  It
only worsens the situtiaotn.

To fix this, someone with the hardware ultimately needs to debug
XFree86 debug build in gdb for XFree86, single step through
the driver, find out where modelines are getting killed,
and then check the internal state of the video driver to find
out why.

Is this critical to people with this laptop?  Probably.  How much
can I do about it?  I have no idea. I dont have the hardware
to debug with.

Trying to troubleshoot a bug that happens on hardware which you
do not have, with a user who is demeaning and demanding is not
a simple thing to do at all.

I fully realize how the whole world will want to use Linux on the
desktop, and "expect" things to work as they do in Windows.  That
simply is NOT going to happen anytime soon however.  Those expectations
sound good in theory, but it just is not reality in Linux right now.

I will try to fix what I can out of the 300-400 bug reports on my
plate, and hopefully get 40-50 of them fixed before another 600
pile on.  Hopefully only 200 of those 600 users will flame me for
things not working like they do in Windows (despite the fact that
it is really an XFree86.org problem, not a Red Hat one.  We do not
create/produce XFree86.  We just _use_ it in our distro, and provide
over 100 bugfixes (more than pretty much anyone else).



Comment 13 Don Hardaway 2002-08-27 10:29:19 EDT
First, I apologise for anything that I said that offended you. We are in the
same boat (Linux) and both would like to see MS crash and burn.  If I had the
money I would send you a dell notebook to work with. Short of that I have
already written Dell and said if they do not work with RH to try to make their
hardware work with RH linux I will never buy dell again nor recommend it to my
University or anyone else.  I understand the bias that hardware companies are
exhibiting with supporting Windows.  I will continue to do what I can.  Thank
you for your efforts. They mean a lot not just to me but the world that is
trapped by that spoiled brat that runs MS.  I am just a little anxious since I
want to demonstrate how Linux can replace Windows right now for common desktop
use to businesses, universities and my students using my laptop.  Until I can
get the screen thing fixed, I don't want to demo it.  Let me know if there is
anything I can do to help.  Thank You.
Comment 14 Don Hardaway 2002-08-27 16:37:18 EDT
Just an update on screen problems. I am noticing after launching some
applications--for example i launched services to turn off kudzu-- and then
wanted to logout of Gnome--as i clicked logout the screen went "White" just as
it does sometimes when returning from a console screen using ctl alt F7.
Comment 15 Don Hardaway 2002-08-29 12:38:18 EDT
I don't know if this helps to diagnose the problem but I have learned that when
I increase the Vertical refresh rate to 110, I can get my resolution down to
1280x960.  Before that I increased the upper V refresh from the 85 that you get
when you choose the Dell 1280X laptop screen to 90 by choosing the 1600x laptop
screen and then i could get 1280X1024.  There seems to be a correlation between
increasing the upper Vertical Refresh rate and being able to lower the screen
resolution. I have not tried above 110 to see if I could get the desired
1024x768. I thought I would wait for your advice first.
Comment 16 Don Hardaway 2002-09-11 15:33:54 EDT
I have sent the requested files and have not heard a word.  I something else
needed. Resolution is still and problem and might prove to be a bigger issue
with the upcoming Desktop release recently announced.  Many companies I know of
have Dell laptops.
Comment 17 Mike A. Harris 2002-12-19 05:39:54 EST
Rawhide XFree86 fixes this problem and other problems on Dell laptops.
Comment 18 Don Hardaway 2002-12-19 19:29:42 EST
Way to go Mike. If my dell laptop problems are over in X, I owe you lunch or
dinner or both.

Note You need to log in before you can comment on or make changes to this bug.