Bug 716369 - nocpulse-common-2.1.22 cannot be installed because of missing perl(RHN::DB) dependency
nocpulse-common-2.1.22 cannot be installed because of missing perl(RHN::DB) d...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nocpulse-common (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
: Reopened
Depends On: spacewalk-web
Blocks: 715745
  Show dependency treegraph
 
Reported: 2011-06-24 04:15 EDT by Petr Pisar
Modified: 2011-09-13 11:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-13 11:44:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2011-06-24 04:15:47 EDT
nocpulse-common-2.1.22 uses perl(RHN::DB):

/perl-API/NOCpulse/NOCpulseini.pm:8:use RHN::DB;

which is exported to binary package as run-time dependency:

$ repoquery --repoid dist-f16 --require 'nocpulse-common' |sort
/bin/sh
httpd
openssh
perl(base)
perl(Carp)
perl(DBI)
perl(IO::AtomicFile)
perl(LWP::UserAgent)
perl(:MODULE_COMPAT_5.12.3)
perl(RHN::DB) ←
perl(strict)
perl(Test::Unit::TestCase)
perl(vars)
/sbin/runuser
/usr/bin/perl
/usr/sbin/useradd

but perl(RHN::DB) is not provided by any package in Fedora 16.
Comment 1 Petr Pisar 2011-08-30 09:02:14 EDT
nocpulse-common-2.1.22-3.fc16 can be installed now because perl(RHN::DB) is provides by spacewalk-base-minimal-1.6.18-1.fc16 now.
Comment 2 Petr Pisar 2011-08-30 10:07:06 EDT
Oops. spacewalk-base-minimal-1.6.18-1.fc16 is not stable in F16 yet. One can close this bug report once the package gets stable.
Comment 3 Petr Pisar 2011-09-13 11:44:27 EDT
nocpulse-common-2.1.22-3.fc16 is installable now.

Note You need to log in before you can comment on or make changes to this bug.