Bug 716388 - kexec-tools doesn't compile on ARM
kexec-tools doesn't compile on ARM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Américo Wang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2011-06-24 05:28 EDT by Peter Robinson
Modified: 2012-01-28 12:43 EST (History)
3 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-28 12:43:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2011-06-24 05:28:31 EDT
The package fails to build on arm

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=101799


gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=armv5te -fno-strict-aliasing -Wall -Wstrict-prototypes -I./include -I./util_lib/include -Iinclude/ -I./kexec/arch/arm/include  -c -MD -o kexec/arch/arm/kexec-elf-rel-arm.o kexec/arch/arm/kexec-elf-rel-arm.c
gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=armv5te -fno-strict-aliasing -Wall -Wstrict-prototypes -I./include -I./util_lib/include -Iinclude/ -I./kexec/arch/arm/include  -c -MD -o kexec/arch/arm/kexec-zImage-arm.o kexec/arch/arm/kexec-zImage-arm.c
kexec/arch/arm/kexec-zImage-arm.c:14:22: fatal error: asm/page.h: No such file or directory
compilation terminated.
make: *** [kexec/arch/arm/kexec-zImage-arm.o] Error 1
Comment 1 Neil Horman 2011-06-24 15:28:47 EDT
I've updated rawhide to kexec-tools-2.0.2, which has arm arch support.  i don't have build infrastructure to test it out though.
Comment 2 Peter Robinson 2011-06-24 19:22:40 EDT
You can test it with "arm-koji build dist-f14 git:// url to mainline build" (we don't have F-16 just yet.... soon). Any chance of getting this in F-15/F14 as well?
Comment 3 Neil Horman 2011-06-27 07:43:57 EDT
I'd like to see some functional kexec testing in rawhide before I backport a new version to avoid regression.  I'll do a build test today.  If you've got any systems running rawhide that you can test the new kexec on, that would be a good step to looking at a f15 backport
Comment 4 Neil Horman 2011-06-27 10:06:02 EDT
hm, build seems to be failing, but not (yet) for any code compilation issue.  Any idea whats going on here:
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=104547
Comment 5 Peter Robinson 2011-06-27 10:19:01 EDT
Its an issue with a perl dep (see the root.log) that I just fixed in the repository. It should be OK in around 30 mins when the build repo has regenerated.
Comment 6 Peter Robinson 2011-06-29 05:54:45 EDT
I resubmitted this as http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=107105
Comment 7 Fedora Admin XMLRPC Client 2011-07-15 11:01:50 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Peter Robinson 2012-01-28 12:43:16 EST
compiles fine with latest rawhide release

Note You need to log in before you can comment on or make changes to this bug.