Bug 716436 - Virtual Machine Manager fails to create VM for Windows 2k8 Server.
Virtual Machine Manager fails to create VM for Windows 2k8 Server.
Status: CLOSED DUPLICATE of bug 678555
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-24 08:31 EDT by Darryl L. Pierce
Modified: 2015-06-21 20:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-29 11:55:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Darryl L. Pierce 2011-06-24 08:31:20 EDT
Description of problem:

In trying to create a VM for Windows 2008 Server, I consistently get an error. I was able to create VMs for Fedora 15 (32- and 64-bit) without issue.


Version-Release number of selected component (if applicable):

virt-manager-0.8.7-4.fc15.noarch


How reproducible:

100%


Steps to Reproduce:
1. Create a new VM in VMM
2. Select a Windows 2008 ISO image downloaded from MSDN.
3. Finish configuring the system (1G RAM, 50G virtual disk, single NIC) and click finish.
  
Actual results:

The error message listed below.


Expected results:

A virt-viewer window that shows me the VM starting up and running.


Additional info:

The error I see in the dialog is:

Unable to complete install: 'Unable to create cgroup for Windows2k8Server: No such file or directory'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 1643, in do_install
    guest.start_install(False, meter=meter)
  File "/usr/lib/python2.7/site-packages/virtinst/Guest.py", line 1187, in start_install
    start_xml, final_xml, is_initial)
  File "/usr/lib/python2.7/site-packages/virtinst/Guest.py", line 1246, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 1346, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: Unable to create cgroup for Windows2k8Server: No such file or directory

However at this point the virtual disk DOES exist in /var/lib/libvirt/images/ and is as large as expected.
Comment 1 Cole Robinson 2011-06-29 11:55:38 EDT

*** This bug has been marked as a duplicate of bug 678555 ***

Note You need to log in before you can comment on or make changes to this bug.