Bug 716446 - new wireless connections stuck "setting network address", often crashes Plasma
new wireless connections stuck "setting network address", often crashes Plasma
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement (Show other bugs)
15
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 717188 717964 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-24 09:30 EDT by Rex Dieter
Modified: 2011-06-30 14:58 EDT (History)
10 users (show)

See Also:
Fixed In Version: kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-30 14:58:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2011-06-24 09:30:19 EDT
Seems updating to NetworkManager-0.8.9997-4.git20110620.fc15 introduces a small regression when used with kde-plasma-networkmanagement-0.9-0.47.20110323.fc15.1 in that new wireless connections seem get stuck doing "setting network address" and never completes.

However, after a session restart (logout/login), the wireless interface then works.

Also tested newer,
kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15
which works well, and does not exhibit this behavior.
Comment 1 Fedora Update System 2011-06-24 09:33:46 EDT
kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15
Comment 2 Kevin Kofler 2011-06-24 13:37:43 EDT
Unfortunately, a session restart is reported not to always help, and consequences of the bug can go as far as plasma-desktop crashing outright.
Comment 3 Fedora Update System 2011-06-24 13:58:30 EDT
Package kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15
then log in and leave karma (feedback).
Comment 4 Danny Brodzik 2011-06-26 03:17:35 EDT
The update does allow me to connect, but it won't connect automatically anymore. I have to click on the icon, then the name of the network I want to connect to. Not that big a deal, but it's a regression.
Comment 5 Kevin Kofler 2011-06-26 03:23:39 EDT
I'm also having trouble with autoconnect with
kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15, I guess we need to file an upstream bug for that too. (I already filed https://bugs.kde.org/show_bug.cgi?id=276485 and https://bugs.kde.org/show_bug.cgi?id=276486 for WPA-EAP secrets trouble.)
Comment 6 Kevin Kofler 2011-06-28 09:21:07 EDT
*** Bug 717188 has been marked as a duplicate of this bug. ***
Comment 7 Joe Christy 2011-06-28 12:38:10 EDT
I, too, experienced this bug and confirm that kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15 fixes it.

(In reply to comment #4)
> The update does allow me to connect, but it won't connect automatically
> anymore. I have to click on the icon, then the name of the network I want to
> connect to. Not that big a deal, but it's a regression.

Amazingly enough, I have just the opposite experience.
I regularly use one of three available wifi networks, which I had set up by hand (due to keys &c) and configured not to connect automatically (since connection speeds among the networks vary in unpredictable ways across time).
Since upgrading kde-plasma-networkmanagement, I now have "Auto <SSID>" Connections that appeared out of nowhere and NM somehow chooses among and automatically connects to w/o my intervention!
Comment 8 Kevin Kofler 2011-06-30 13:22:50 EDT
*** Bug 717964 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2011-06-30 14:58:38 EDT
kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.